August12345
01.02.2021 20:47

Напишите программу с интерфейсом visual basic Функцию выделяющую первую подстроку из строки по начальному и конечному символу. Проверить, не выходит ли конечный символ за пределы строки.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lera1059
27.11.2022 04:03
uses crt; var s:string;     c:char;     m:set of char;     n,i,k,p:byte; begin writeln('Введите текст из строчных латинских букв, окончаание ввода Enter'); s:=''; repeat c:=readkey; if c in ['a'..'z'] then  begin   write(c);   s:=s+c;  end; if c=#13 then writeln until c=#13; n:=length(s); m:=[]; for c:='a' to 'z' do  begin   k:=0;   for i:=1 to n do   if s[i]=c then k:=k+1;   if k>1 then m:=m+[c];  end; if m=[] then write('Нет букв, встречающихся более 1 раза') else  for c:='a' to 'z' do  if c in m then write(c) end.
0,0(0 оценок)
Ответ:
12abgh
20.03.2022 17:38
Запомни: в 1 байте 8 бит, в 1 Кбайте 1024 байт, 1 Мегабайте = 1024 кбайт, 1 Гигабайт = 1024 мегабайт.
Исходя из этого имеем (приведём всё к битам):
1) 5 бит
2) 15 байт = 15*8 бит = 120 бит
3) 1024 килобайт = 1024*1024 байт = 1048576 байт = 1048576 *  8 бит = 8388608 бит
4) 1024 мегабайт = 1024*1024*1024*8 бит = 8589934592 бит
5) 15 килобайт = 15*1024*8 бит = 122880 бит

Таким образом:
5 бит → 15 байт → 15 килобайт → 1024 килобайт → 1024 мегабайт

(хотя здесь и вычислять ничего не нужно - всё итак очевидно и без расчётов)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота