unicorn2837
22.08.2022 00:55

На вход программе подается натуральное число n, затем n строк, затем еще одна строка — поисковый за Напишите программу, которая выводит все введенные строки, в которых встречается поисковый за Формат входных данных
На вход программе подаются натуральное число nn — количество строк, затем сами строки в указанном
количестве, затем один поисковый за Формат выходных данных
Программа должна вывести все введенные строки, в которых встречается поисковый за Примечание. Поиск не должен быть чувствителен к регистру символов.
Пример входных данных:
5
Я вас любил: любовь еще, быть может,
В душе моей угасла не совсем;
Но пусть она вас больше не тревожит;
Я не хочу печалить вас ничем.
Я вас любил безмолвно, безнадежно,
Любил
Вывод программы:
Я вас любил: любовь еще, быть может,
Я вас любил безмолвно, безнадежно,

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
arifmametov1
20.05.2020 14:17
Program lol (input, output);
var a, n, b, i, p,s,g m:integer;
c:real;
begin
n:=Random(10000);
writeln (n);
a:=n;
b:=0;
c:=0;
p:=1;
g:=1;
while a <> 0 do
begin
a:=a div 10;
b:=b+1;
end;
while b <> 0 do
begin
p:=1;
for m:=1 to b do
p:=p*10;
s:=(n mod p) div (p div 10);
c:=c+s;
g:=g*s;
b:=b-1;
end;
writeln (c);
writeln (g);
end.

program lol (input, output);
var a, b, i, z:integer;
begin
b:=0;
a:=3;
z:=0;
while a > 2 do
begin
read (a);
z:=0;
for I:=2 to a do
begin
if a mod I = 0 then
begin
z:=z+1;
if (a=I) and (z=1) then
b:=b+1;
end;
end;
end;
writeln (b);
end.
0,0(0 оценок)
Ответ:
madina319
20.05.2020 14:17
Program lol (input, output);
var a, n, b, i, p,s,g m:integer;
c:real;
begin
n:=Random(10000);
writeln (n);
a:=n;
b:=0;
c:=0;
p:=1;
g:=1;
while a <> 0 do
begin
a:=a div 10;
b:=b+1;
end;
while b <> 0 do
begin
p:=1;
for m:=1 to b do
p:=p*10;
s:=(n mod p) div (p div 10);
c:=c+s;
g:=g*s;
b:=b-1;
end;
writeln (c);
writeln (g);
end.

program lol (input, output);
var a, b, i, z:integer;
begin
b:=0;
a:=3;
z:=0;
while a > 2 do
begin
read (a);
z:=0;
for I:=2 to a do
begin
if a mod I = 0 then
begin
z:=z+1;
if (a=I) and (z=1) then
b:=b+1;
end;
end;
end;
writeln (b);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота