ksjsksskskjns
19.03.2021 11:17

Напишите программу на паскаль: Задан двумерный массив случайных чисел. элементы оканчивающиеся цифрой 3 увеличить на сто. нужно что бы в ответе присутствовала как начальный, так и изменённый массив

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
blik5
04.04.2023 11:01

Program zadacha;

Const n = 10;

Type mas=array[1..n] of integer;

Var s,i,k,d:integer;

m:mas;

Begin

s:=0;

k:=0;

readln(d);

For i:=1 to n do

read(m[i]);

For i:=1 to n do

if m[i]<d then begin

s:=s+m[i];

k:=k+1;

end;

writeln('Сумма чисел < d = ',s,' Колиество чисел < d = ',k);

end. (Это решение для случая если вы вводите сразу весь массив чисел)


Program zadacha;

Const n = 10;

Var s,i,k,d,m:integer;

Begin

s:=0;

k:=0;

readln(d);

for i:=1 to n do begin

readln(m);

if (m < d) then begin

s:=s+m14;

k:=k+1;

end;

end;

writeln('Сумма чисел < d = ',s,' Колиество чисел < d = ',k);

end. (А это решение для того случая когда вы вводите элементы по одному )

0,0(0 оценок)
Ответ:
lilikykytik21
28.02.2022 22:26

#include <iostream>

int main() {

const int SIZE = 10;

bool isSence = false;

int sum = 0;

int count = 0;

int arr[SIZE];

for (int i = 0; i < SIZE; i++)

{

 arr[i] = rand() % 20 - 10; // "рандомно" заполняем массив от -10 до 10

 std::cout << arr[i] << "\t"; // выводим массив в консоль

 if (arr[i] >= 0)

  isSence = true;

}

for (int i = 0; i < SIZE; i++)

{

 if ((isSence) && (arr[i] > 0))

  sum += arr[i]; //sum = sum + arr[i];

  count++;

}

if (isSence)

 std::cout << "\nсреднее арифметическое положительных чисел = " << double(sum) / count << std::endl; // явное приведение типов

else

 std::cout << "\nВ массиве нету положительных чисел или нету нулей и/или отрицательных чисел" << std::endl;

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота