veragmyr
19.11.2020 21:33

В качестве проекта необходимо написать программу для нахождения разности факториалов наименьшего и наибольшего чисел из N введенных с использованием структур языка JavaScript. Пример:

Вводится N=5;

Вводится N(в данном случае 5) чисел: 1,2,3,4,5;

Находится наибольшее и наименьшее из них: 5 и 1 соответственно;
Вычисляется разность факториалов наименьшего и наибольшего чисел из N введенных: 1!-5!=-119
Требования к выполнению проекта: наличие написанной функции, циклов и условий.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Kravtskris
28.07.2020 01:03

Обычно предполагается, что нам известны какие-либо начальные данные. Тогда для простоты, буду считать что нам известно основание и высота к этому основанию. В таком случае

S = основание * высоту / 2

Что нужно сделать?

1) Запросить у пользователя ввод длины основания

2) Запросить у пользователя ввод длины высоты

3) Вычислить площадь

4) Вывести площадь на экран

Определимся с данными. У нас будет переменная S, основания и высоты. Все будут real, ведь пользователь может ввести и не целое число.

program ploshad;

var S, osnovanie, visota:real;

begin

   writeln('Вычисление площадь треугольника по основанию и высоте');

   writeln('Введите длину основания ');

   read(osnovanie);

   writeln('Введите длину высоты ');

   read(visota);

   S:=osnovanie*visota/2;

   writeln('Площадь треугольника = ',S);

end.

0,0(0 оценок)
Ответ:
pro100rak2
06.09.2021 09:32
Var
    A: array[1..100, 1..100] of integer;
    B: array[1..100]of integer;
    i, j, k, n, m, imax: integer;
    manual: boolean;

begin
    writeln('Ручной ввод (true/false)==>');
    read(manual);
    
    if manual then begin
        writeln('Размер массива n, m ==>');
        read(n, m);
    end
    else begin
        n := random(10) + 5;
        m := random(10) + 5;
    end;
    
    for i := 1 to n do
    begin
        writeln();
        for j := 1 to m do
        begin
            if manual then
                read(a[i, j])
            else begin
                a[i, j] := random(100) - 50;
                write(a[i, j]:3, ' ');
            end;
        end;
    end;
    
    writeln();
    writeln();
    
    for j := 1 to m do
        if j mod 2 = 1 then begin
            k := k + 1;
            b[k] := 1;
            for i := 1 to n do
                b[k] := b[k] * a[i, j];
            write(b[k], ' ');
        end;
    
    writeln();
    
    for i := 1 to k - 1 do
    begin
        imax := i;
        for j := i + 1 to k do
            if b[j] > b[imax] then
                imax := j;
        n := b[i];
        b[i] := b[imax];
        b[imax] := n;
    end;
    
    for i := 1 to k do
        write(b[i], ' ');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота