натали524
13.03.2022 08:15

Составьте программу которая копирует из строки "наступила холодная зима " слово "зима"

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
svesda2
23.02.2020 12:33
Const
  destinations = 'СЗЮВСЗЮВСЗЮВ';    {Предварительно сформированная строка ориентаций}
var
  C : char;
  N1, N2, Position : integer;
begin
  write('Исходная ориентация локатора: ');
  readln(C);
  write('Первая команда поворота: ');
  readln(N1);
  write('Вторая команда поворота: ');
  readln(N2);
  Position := Pos(C, destinations) + 4;   {Устанавливаем позицию на положение заданного направления}
  Position := Position + N1; {Направление после первого поворота (Определяется destinations[Pos])}
  Position := Position + N2; {Направление после второго поворота (Определяется destinations[Pos])}
  writeln('Конечная ориентация: ', destinations[Position]);
end.  
0,0(0 оценок)
Ответ:
Айхан111111111
12.07.2022 16:18
Сказано было сформировать массивы с имененем А и В. Заполняем их целыми числами, так что и  объявить массивы можно как целые. Но это мелочи, не обязательные.
var    
a, b: array[1..20]of integer;  
  i, s,n: integer;    
begin  
   writeln('Массив А:');
   randomize;     
   for i := 1 to 20 do  
     begin     
     a[i] := random(100) - 50;
     write(a[i],' ');     
     if (a[i] > 0) and (i mod 2 = 0) then
        begin
        n:=n+1;   
        b[n]:= a[i];        
        s := s + b[n] * b[n];  
        end;
     end;
   writeln();
   writeln('Массив В:');
   for i:=1 to n do write(b[n]);
   writeln;
   writeln('S = ', s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота