ivanural
11.03.2022 15:56

Программа Паскаль 1.Написать программу,
которая по введенному номеру дня недели выводит одно из сообщений «Рабочий день», «Выходной день»
2.Написать программу,которая по введённому номеру дня недели выводит на экран монитора его название на русскому языке

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Elli34
27.03.2022 02:04

Відповідь:

Pygame — набор модулей (библиотек) языка программирования Python, предназначенный для написания компьютерных игр и мультимедиа-приложений. Pygame базируется на мультимедийной библиотеке SDL.

Изначально Pygame был написан Питом Шиннерсом. Начиная примерно с 2004-2005 года поддерживается и развивается сообществом свободного программного обеспечения.

Pygame – это библиотека модулей для языка Python, созданная для разработки 2D игр. Также Pygame могут называть фреймворком. В программировании понятия "библиотека" и "фреймворк" несколько разные. Но когда дело касается классификации конкретного инструмента, не все так однозначно.

В любом случае, фреймворк является более мощным по-сравнению с библиотекой, он накладывает свою специфику на особенности программирования и сферу использования продукта. С точки зрения специфики Pygame – это фреймворк. Однако его сложно назвать "мощным инструментом". По своему объему и функционалу это скорее библиотека.

Также существует понятие "игрового движка" как программной среды для разработки игр. По своему назначению Pygame можно считать игровым движком. В то же время, с точки зрения классификации программного обеспечения, Pygame является API для Питона к API библиотеки SDL.

API – это интерфейс (в основном набор функций и классов) для прикладного (часто более высокоуровневого) программирования, который предоставляет, например, та или иная библиотека. SDL – это библиотека, которая работает с мультимедийными устройствами компьютера.

В этом смысле Pygame можно сравнить с Tkinter, который через свои функции и классы предоставляет Питону доступ к графической библиотеке Tk.

Пояснення:

0,0(0 оценок)
Ответ:
lizasereda05
16.08.2020 01:40
//вот так компилируется без ошибок

uses crt;
var k:integer;
n:integer;
begin
clrscr;
k:=0;
writeln('Тест по теме "Циклы"');
writeln('Вопрос 1. Алгоритм называют циклическим, >');
writeln('если в нем:');
writeln('1)Реализуется многократно повторяющаяся');
writeln(' последовательность действий');
writeln('2)Используются повторяющиеся праметры');
writeln('3)Много раз используются одни и те же операторы');
writeln('4)Используются команда выбора');write('Введите номер правильного ответа:');
read(n);
if n=1 then k:=k+1;
writeln('Вопрос 2. Сколько раз будет выполнятся цикл,<');
writeln('если начальное значение параметра -6');
writeln('конечное значение 6,');
writeln('шаг изменения параметра равен 3');
writeln('1)6 раз');
writeln('2)5 раз');
writeln('3)4 раз');
writeln('4) Не выполнится ни разу');
write('Введите номер правильного ответа:');
read(n);
if n=2 then k:=k+1;
case k of
1,2:writeln('Плохо');
3: writeln('Удовлетворительно');
4: writeln('Хорошо');
5: writeln('Отлично');
end;
readkey;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота