instajohap091g2
15.02.2022 02:54

№1

1. Понятие структурного программирования. Базовые алгоритмические структуры.

2. Составить графический алгоритм вычисления разности 254 и 152.

№2

1. Сложные алгоритмические структуры. Этапы решения задач на ЭВМ.

2. Составить программу на языке Турбо Паскаль для вычисления суммы 85 и 15.

№3

1. Алгоритм, его свойства и описания.

2. Составить программу на языке Турбо Паскаль для вычисления разности 85 и 15.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kskskdksks
24.09.2021 17:59

Объяснение:

using System;

namespace ConsoleApp2

{

   class Program

   {

       static void Main(string[] args)

       {

           bool InArea = false;

           Console.Write("R=");

           double R = double.Parse(Console.ReadLine());

           Console.Write("x=");

           double x = double.Parse(Console.ReadLine());

           Console.Write("y=");

           double y = double.Parse(Console.ReadLine());

           // Проверяем попадает ли в полукруг

           if (x <= 0 && y >= 0 && x * x + y * y <= R * R) InArea = true;

           // Проверяем попадает ли в первую половинку треугольника

           // Уравнение прямой будет y=-2x  

           if (x > 0 && x <= R/2.0 && y >= -2*x && y<=0) InArea = true;

           // Проверяем попадает ли во вторую половинку треугольника

           // Уравнение прямой будет y=2x-2R  

           if (x > 0 && x <= R / 2.0 && y >= 2 * x - 2 * R && y <= 0) InArea = true;

           if(InArea) Console.WriteLine("Точка принадлежит области");

           else Console.WriteLine("Точка не принадлежит области");

           Console.ReadLine();

       }

   }

}

0,0(0 оценок)
Ответ:
sitkavetskiy
16.10.2020 15:02

Интернет символ «@» появился несколько сотен лет назад в средневековых монастырях. Его использовали для обозначения латинского предлога «ad» (в современном английском — «at»), хотя некоторые исследователи утверждают, что «собаку» придумали итальянские монахи.

Как бы то ни было, это новшество вскоре переняли торговцы: одним из первых, кто использовал символ вне стен монастыря, был флорентийский купец Франческо Лапи, в одном из своих писем обозначивший «собакой» амфору — стандартную в те времена меру объёма, примерно равную 26-ти л.

Постепенно знак стал приобретать и другие значения, например, в португальском, испанском и французском языках до символа «@» обычно сокращают старинную испанскую меру веса под названием «arroba», равную 11,502 кг. Символ, похожий на «собаку», исследователи обнаружили в русских книгах XVI–XVII веков, в числе которых — Судебник Ивана Грозного, датируемый 1550-м годом, а к XIX-му веку знак уже получил широкое распространение в качестве обозначения единицы товара.

Рэй Томлинсон

В 1963-м году появилась кодировка стандарта ASCII, в числе 95-ти печатных знаков которой присутствовала и «собака», а в 1973-м году члены организации «Internet Engineering Taskforce» закрепили использование знака при разделении имени и домена — эту идею в 1971-м году выдвинул программист Рэй Томлинсон. Массовой «собака» стала в 1996-м году, когда появился сервис «Hotmail».

Кстати, «собакой» символ называют лишь русские и украинцы, в других языках этот знак известен под другими, порой достаточно необычными именами. Итальянцы говорят «chiocciola» («улитка»), в Греции его знают, как «παπακι» — «уточка», в Чехии и Словакии — «zavináč» («рулетик из сельди»), на Тайване используют понятие «小老鼠» (произносится как «сяо лао шу») — «мышка», в Израиле распространено название «שטרודל» — «штрудель», а в Казахстане знак именуют «айқұлақ» — «ухо Луны».

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота