Noname010203
22.07.2022 12:47

Дан массив размерностью 6х5. Написать программу вычисления произведения элементов массива по модулю меньших максимального элемента в 2 раза На Pascal

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
olyailysha31
15.01.2022 02:46
Занумеруем монеты 1,2,3,4,5,6. Предполагается, что фальшивые монеты весят одинаково. 
1) Кладем на левую чашу 1,2,3, а на правую - 4,5,6 
Рассмотрим 2 возможных случая. 
Случай 1 
2) Предположим, левая чаша перевесила. Значит, обе фальшивые монеты на правой. Кладем на левую 4, на правую 5. Если равновесие, то обе они фальшивые. Если какая-то легче, например, 5, то она фальшивая и фальшивая оставшаяся 6. Понадобилось всего 2 взвешивания. 
Случай 2 
2) Теперь предположим, что весы в равновесии. Тогда каждая из троек содержит по одной фальшивой монете. Кладем на левую 1, на правую 2. Если равновесие, то обе они фальшивые. Если какая-то легче, например, 1, то она фальшивая и фальшивая оставшаяся 3. 
3) Кладем на левую 4, на правую 5. Если равновесие, то обе они фальшивые. Если какая-то легче, например, 5, то она фальшивая и фальшивая оставшаяся 6.
0,0(0 оценок)
Ответ:
san11217
26.10.2022 14:17
Var a: string;
    words, nums, chars, i, sen: integer;
begin
     readln(a);
     words := 1;
     For i := 1 to Length(a) do
         begin
         If (a[i] = ' ') then inc(words);
         if (a[i] in ['0'..'9']) then inc(nums);
         if (a[i] = #13) then inc(sen);
         if (a[i] in ['a'..'z', 'A'..'Z', 'а'..'я', 'А'..'Я']) then inc(chars);
     end;
     writeln(Words, ' words', #13, Chars, ' chars (', Nums, ' Numbers)', #13, Sen, ' sentences');
end.

Разве что на строки проверить не могу, т.к. у меня только PascalABC, но должно работать =)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота