Saaabiii
02.10.2020 20:25

Язык паскаль, можно через while написать программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор пока не будет введён ноль) и подсчёт суммы введённых положительных чисел. используйте оператор repeat

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Grizzly23
12.06.2020 20:58

Объяснение:

Pascal

var a,i,s,n:integer;

begin

 s:=0;

 n:=0;

 repeat

    readln(a);

    if a>0 then begin

       n:=n+1;

       s:=s+a;

    end;

 until a = 0;

 writeln('Сумма ',s:5,'  Среднее арифметическое ',s/n);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота