Алтын12938849к9ку9
09.10.2021 10:54

Программный код, который сравнивает длины двух встроенных строк написать.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vadimnigamaev
03.07.2022 06:32

Начало отсчета лет - 1984 год. Надо написать программу (pascalABC). Вводите год, нужный вам, отнимаете от него 1984 и находите остаток от деления на 12. Последовательность животных в 12-летнем цикле - крыса, корова, тигр, заяц, дракон, змея, лошадь, овца, обезьяна, курица, собака, свинья. То есть если при делении на 12 остаток равен 0, значит введенный год - год крысы, если 1 - год коровы и т.д.

Программа: 

var a,b,c:longint;
begin
write('Введите год: ');
readln(a);
c:=a-1984;
b:=c mod 12;
case b of
0:writeln(a,' - год крысы');
1:writeln(a,' - год коровы');
2:writeln(a,' - год тигра');
3:writeln(a,' - год зайца');
4:writeln(a,' - год дракона');
5:writeln(a,' - год змеи');
6:writeln(a,' - год лошади');
7:writeln(a,' - год овцы');
8:writeln(a,' - год обезьяны');
9:writeln(a,' - год курицы');
10:writeln(a,' - год собаки');
11:writeln(a,' - год свиньи');
end;
end.

0,0(0 оценок)
Ответ:
a6271547
18.05.2022 07:47


1)1. Анализ задачи, поиск решения, выбор/разработка оптимального алгоритма
2. Составление/анализ выходных выходных данных для алгоритма
3. Составление/анализ данных для промежуточных вычислений
4. реализация алгоритма на языке программирования
5. тестирование программного кода и сопоставление выходных результатов с поставленой задачей

2) описание задачи математическим языком, в виде формул, зависимостей, закономерностей, последовательностей, понятий

3) поэтапная покомпонентая построчная проверка программного кода с целью осознания того что код работает
так как задумано. Тест это операция над объектом, программой, позволяющая проверить правильность работы

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота