romanchuknina
01.09.2020 05:46

Составить программу перевода английской меры длины дюйм в метры, если известно, что один дюйм равен 2,54см.


Составить программу перевода английской меры длины дюйм в метры, если известно, что один дюйм равен

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
кузя215
09.06.2023 09:47

4 бита, это комбинация из 4-х чисел, от 1 до 0.  

Максимальное число, которое можно закодировать 4 битами это 1111 в двоичной системе, а в 10-тичной системе это число 15 (8+4+2+1).  

Итого у его может быть максимум 15 пятерок.  

Если допустить, что он получил максимум 5-ток, а это15, то тогда 160-15=145 четверок получил.  

Но, если он получил 14 оценок, это по прежнему будет 14 бит, но комбинация будет 1110.  

13 - 1101, 12 - 1100, 11 - 1011, 10 - 1010, 9 - 1001, 8 - 1000, 7 -111.  

Исходя из некоректных условий задачи, мы можем знать только то, что пятерок у ученика от 8 до 15 (8, первое число которое кодируется 4-ю битами, и 15 которое последнее).  

Задача,увы, неправильная.

Объяснение:

0,0(0 оценок)
Ответ:
BekaBeka001
07.09.2022 04:04

Объяснение:

1) Без составных условий.

program abc;

 var x,y,v:real;

begin

 readln(x,y);

 

  if (x>1) then

   begin

    if (y>1) then

     v:=x+y

    else

     v:=x-y;

   end

  else begin

   if (y>1) then

     v:=-x+y

    else

     v:=-x-y;

  end;

writeln(v);

end.

2) С составным.

program abc;

 var x,y,v:real;

begin

 readln(x,y);

if (x>1) and (y>1) then

  v:=x+y;

if (x>1) and (y<=1) then

  v:=x-y;

if (x<=1) and (y<=1) then

  v:=-x-y;

if (x<=1) and (y>1) then

  v:=-x+y;

writeln(v);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота