Сашакозлов13лет
24.01.2020 01:12

Составить программу в виде процедуры и функции для нахождения площади прямоугольного треугольника в Паскале. ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ольга198414
23.10.2022 15:25
Программу надо сформатировать и тогда её структура будет видна лучше.
А чтобы понять, как идет выполнение, в нужных точках ставим промежуточную выдачу - это называется "трассировкой".

var
  s, k: integer;
label
  met;
begin
  s:=-12;
  k:=90;
  Writeln('s=',s,', k=',k);
  s:=s+10;
  Writeln('s=',s);
met:
  Writeln('Метка met:');
  k:=k+10; Write('k=',k);
  if k<200 then s:=50 else s:=s+k;
  Writeln(', s=',s);
  if k<200 then goto met;
  Writeln('Результат: s=',s)
end.

Результат выполнения программы:
s=-12, k=90
s=-2
Метка met:
k=100, s=50
Метка met:
k=110, s=50
Метка met:
k=120, s=50
Метка met:
k=130, s=50
Метка met:
k=140, s=50
Метка met:
k=150, s=50
Метка met:
k=160, s=50
Метка met:
k=170, s=50
Метка met:
k=180, s=50
Метка met:
k=190, s=50
Метка met:
k=200, s=250
Результат: s=250
0,0(0 оценок)
Ответ:
tyrykina0115
20.07.2020 14:17

K1 = int(input())

M = int(input())

K2 = int(input())

P2 = int(input())

N2 = int(input())

if M != 1:

   for i in range(1,1000):

       if i!=0 and N2==((K2-1)//i)+1:

           P1 = (((K1-1)//i)//(M-1))+1

           N1=(((K1-1)//i)%(M-1))  

if M == 1:

   N1 = 1

   for i in range(1,1000):

       if i!=0:

           while K1 % i != 0:

               K1 = K1 + 1

           P1 = (K1//i)

if K2 < P2 * N2 or N2 > M or K2 // P2 < M:

   P1 = -1

   N1 = -1

if P2 == 1 and N2 == 1:

   P1 = -1

print(P1, N1)

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота