АмелияРайс
07.01.2023 15:15

Впаскаль абс. в эвм поступают результаты соревнований по плаванию для трех спортсменов. составьте программу, которая выбирает лучшей результат и выводит его на экран с сообщением, что это лучшей результат.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
DYUK1s
12.06.2020 14:26

var i :integer;

     a, b:real;

begin

for i:=1 to 3 do

     begin

       write ('a=');

       readln(a);

      if (a>b) then b:=a;

     end;

writeln ('a=' , b);

end.

 

0,0(0 оценок)
Ответ:
mun7890
12.06.2020 14:26

const
N = 3;

var
a: array[1..N] of integer;
i, max: integer;

begin
max := 0;
writeln('Введите результаты трех спортсменов');
for i := 1 to N do readln(a[i]);
for i := 1 to N do
begin
if a[i] > max then
max := a[i];
end;
writeln;
writeln('Лучший результат среди трех спортсменов - ', max);
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота