davidgts
06.08.2021 14:49

Написать программу вывода изображения ниже(питон)

* * * *

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lrydg2363
31.07.2021 11:29
1)
#include <iostream>
using namespace std;

int main()
{
  unsigned long long p = 1;
  for (int i = 10; i<=98; i+=2)
    p*=i;
  cout <<"Proizvedenie: " <<p <<endl;
  return 0;
}

2)
#include <iostream>
using namespace std;

int main()
{
  unsigned long long p = 1;
  int i = 10;
  while (i<=98)
  {
    p*=i;
    i+=2;
  }
  cout <<"Proizvedenie: " <<p <<endl;
  return 0;
}

3)
#include <iostream>
using namespace std;

int main()
{
  unsigned long long p = 1;
  int i = 10;
  do
  {
    p*=i;
    i+=2;
  }
  while (i<=98);
  cout <<"Proizvedenie: " <<p <<endl;
  return 0;
}

Столь большое произведение не поместиться даже
unsigned long long,поэтому результатом будет выдавать 0
0,0(0 оценок)
Ответ:
Роза005
27.07.2022 01:54
Pascal:
var n:integer;
     f:boolean;
begin
  f:=false;
  repeat
    write ('N = ');
    readln (n);
  until (n>=1000) and (n<=9999);
  while (not f) and (n<>0) do
   begin
    if n mod 10 = 4 then f:=true;
    n:=n div 10;
   end;
  if f then writeln ('YES') else writeln ('NO');
end.

C++:
#include <iostream>
using namespace std;

int main()
{
  int n;
  bool f = false;
  while (n<1000 || n>9999)
  {
    cout <<"N = ";
    cin >>n;
  }
  while (!f && n!=0)
  {
    if (n%10==4)
      f = true;
  }
  if (f)
    cout <<"YES" <<endl;
  else cout <<"NO" <<endl;
  return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота