leski
28.09.2022 19:51

Написать программу на С Дан массив чисел с плавающей точкой A[N]. Заменить все его элементы, большие введённого с клавиатуры числа Z, этим числом. Подсчитать количество таких замен.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
qalaysiz345
13.03.2021 08:24

Исходник ниже.

Объяснение:

#include <iostream>

#include <cmath>

using namespace std;

int main(){

   //"\t" - табуляция

   //fixed - для вывода фиксированного количества знаков после запятой у вещественного числа

   cout << "x\t\ty\t\ta\t\tb\t\tz" << endl;

   double x = 0.5;

   while(x <= 1.9){

       double y = 0.1;

       while(y <= 0.2){

           double a = cos(x*x*x - sqrt(y));

           double b = pow(x * y * y, 1.0 / 3);

           double z;

           if (a > b){

               z = a;

           }

           else{

               z = b;

           }

           cout << fixed << x << "\t" << y << "\t" << a << "\t" << b << "\t" << z << endl;

           y += 0.05;

       }

       x += 1.1;

   }

   return 0;

}

0,0(0 оценок)
Ответ:

procedure FormMas(a: array[,] of integer; var v: array of int64);

var

 m, n, i, j, k: integer;

begin

 m := length(a, 0);

 n := length(a, 1);

 setlength(v, n);

 for j := 0 to n - 1 do

 begin

   v[j] := 1;

   k := 0;

   for i := 0 to m - 1 do

     if a[i, j] < 0 then

     begin

       k := k + 1;

       v[j] := v[j] * a[i, j]

     end;

   if k = 0 then

     v[j] := 0;

 end;

end;

function KolNul(a: array[,] of integer): integer;

var

 m, n, i, j, k, p: integer;

begin

 k := 0;

 m := length(a, 0);

 n := length(a, 1);

 for j := 0 to n - 1 do

 begin

   p := 0;

   for i := 0 to m - 1 do

     if a[i, j] < 0 then

       p := p + 1;

   if p = 0 then

     k := k + 1;

 end;

 KolNul := k;

end;

var

 m, n, i, j, k: integer;

 a: array[,] of integer;

 b: array of int64;

begin

 read(m, n);

 setlength(a, m, n);

 for i := 0 to m - 1 do

   for j := 0 to n - 1 do

     read(a[i, j]);

 FormMas(a, b);

 for j := 0 to n - 1 do

   write(b[j], ' ');

 writeln;

 k := KolNul(a);

 write(k);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота