yuliaivanova1
22.12.2022 12:32

Напишите программу, принимающую на вход целое число, которая выводит True, если переданное значение попадает в интервал (−15,12]∪(14,17)∪[19,+∞) и False в противном случае

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
svistmi20061
22.11.2022 16:37

УВ 1:

Вначале у тебя а -5, а б-6.

Потом условие: если а меньше трёх, то а становится равной б, но ведь а это 5, т.е. этого мы не делаем.

И последнее: д=а+б=5+6=11

ответ:11

УВ 2:

А=3, б=2.1

Б<а? Да, меньше, т.к. 2.1 меньше 3

Значит выполним действие: напечатаем б, т.е.2.1

Затем в обязательном порядке напечатаем а, т.е.3

В итоге на экране напечатано будет:2.13

Ув3:

А,б,ц равны 3,4,5 соответственно

А меньше 4? Да, меньше, почему печатаем число а,число б и число ц, т.е. будет напечатано 3 4 5.

Иначе напечатолось бы сумма 3,4,5, т.е. 12

Ув4:

М=2

М >2?

Нет, не больше, значит м=м*м, т.е. 4

0,0(0 оценок)
Ответ:
danyadope8
04.11.2021 21:00
Ищем закономерности.

Год: 1, 21, 31, 41, 51, 61, 71, 81, 91, 101
(оканчивается на единицу, исключение: 11 и 111)
Года: 2-4, 22-24, 32-34, 42-44, 52-54, 62-64, 72-74, 82-84, 92-94, 102-104
(оканчивается на 2, 3 или 4, исключения: 12, 13, 14, 112, 113, 114)
Лет: 0, 5-20, 25-30, 35-40, 45-50, 55-60, 65-70, 75-80, 85-90, 95-100, 105-120
(оканчивается на 0, 5-9, плюс исключения из пунктов)
У исключений есть общее: остаток при делении на 100 будет в промежутке от 11 до 14.

n - возраст
Язык программирования: Паскаль

var
n : integer ;
begin
read (n) ;
n := n mod 100 ;
if n in [11..14] then
writeln ('лет');
else
begin
n := n mod 10 ;
case n of
1 : writeln ('год') ;
2..4 : writeln ('года') ;
0, 5..9 : writeln ('лет') ;
end ;
readln ;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота