Pa3goJI6aù
12.01.2020 10:30

Написать программу, которая выводит на экран таблицу стоимости, например, яблок в диапазоне от 100 г до 1 кг с шагом 100. Ниже представлен рекомендуемый вид экрана программы во время ее работы (данные, введенные пользователем, выделены полужирным шрифтом). Введите цену одного килограмма и нажмите (копейки от рублей отделяйте точкой)>> 16.50 НАПИСАТЬ НА ПИТОНЕ
Вес (гр) Стоимость (руб.)
100 1.65
200 3.30
300 4.95
400 6.60
500 8.25
600 9.90
700 11.55
800 13.20
900 14.85
1000 16.50

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Дамир0001
14.03.2020 15:08
Дискретные сигналы (они же цифровые) - принимают конечное число значений функции:
примеры дискр: 
- энергетические уровни атома, 
- сигналы светофора
- символы, слова... и т.д. и т.п.
непрерывный (он же аналоговый) - принимает бесконечное количество значений функции, амлитуда и время которого меняются непрерывно. 
примеры непрерывных: 
- звуковая волна, 
- диаграмма изменения влажности, напряжения, и других некоторых физических величин

для преобразования непрерывного сигнала в дискретные производят дискретизацию. Процесс дискретизации сопровождается потерей информации если частота дискретизации  в 2 раза меньше максимальной частоты непрерывного сигнала по теореме Найквиста... В России эту теорему называют Котельникова.
0,0(0 оценок)
Ответ:
leila323
30.11.2020 07:38
Чтобы квадрат вписался в круг, его диагональ должна быть равна диаметру круга. Если трактовать "уместиться" как "пролезть", то диагональ должна быть меньше диаметра..
Формулы площадей квадрата  S₁ и круга S₂ известны, что легко позволяет нам найти нужное условие.
\displaystyle S_1=a^2 \to a=\sqrt{S_1}; \ d=a \sqrt{2}= \sqrt{2S_1} \\ S_2=\frac{\pi D^2}{4} \to D=\sqrt{\frac{4S_2}{\pi}}; \\ d\ \textless \ D \to \sqrt{2S_1}\ \textless \ \sqrt{\frac{4S_2}{\pi}}; \ 2S_1\ \textless \ \frac{4S_2}{\pi} \ \to \ \boxed{\pi s_1\ \textless \ 2S_2}
Если нужно, чтобы случай, когда квадрат вписан в круг тоже учитывался, строгое неравенство следует заменить нестрогим.

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
  var s1:=ReadReal('Площадь квадрата');
  var s2:=ReadReal('Площадь круга');
  if pi*s1<2*s2 then Writeln('Квадрат умещается в круге')
  else Writeln('Квадрат не умещается в круге')
end.

Тестовое решение:
Площадь квадрата 24.6
Площадь круга 28.4
Квадрат не умещается в круге
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота