228466
24.05.2023 08:10

паскаль Составить программу, которая запрашивает число, если оно положительное, то выводит его. Ввод чисел заканчивается, если ввели ноль

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
toyru556
13.09.2022 20:44
Известно что Боря жил в одной комнате с мальчиком из Кирова и ни один из этих мальчиков не был в Москве, ни в Санкт-Петербурге, то есть Боря был не из Москвы, не из Питера и не из Кирова, остаётся-Омск.Гриша играл в одной команде с мальчиком из Москвы, а вечерами к ним заходил мальчик из Кирова, значит, точно знаем, что Гриша был не из Москвы, не из Кирова, остаются Питер и Омск, но мы уже установили, что из Омска был-Боря, получается, что Гриша был из Питера.  
Егор и мальчик из Москвы увлекались игрой в шахматы, значит, Егор был точно не из Москвы, и при этом мы знаем, что Омск и Питер уже заняты. Остался Киров У нас остался один город Москва и один мальчик, которого зовут Витя, значит, Витя был из Москвы.
ответ:Витя из Москвы, Боря из Омска,Гриша из Санкт-Петербурга, Егор из Кирова. 
0,0(0 оценок)
Ответ:
dariadaria2007
30.04.2023 21:00
Что касается конкретной программы
1. Описываем нужные нам переменные - это будут стороны прямоугольника a и b. Поскольку нигде ничего о размерах сторон не сказано, придется предположить, что они не обязательно будут целыми , мы опишем эти переменные, как вещественные (real), что позволит работать и с нецелыми значениями.
2. Из геометрии нам известны формулы периметра прямоугольника P=2 x (a+b) и площади прямоугольника S=a x b. Можно описать переменные P, S (тоже real), но смысла в этом нет, поскольку значения P и S нужны только для вывода результатов, так что проще написать нужные выражения непосредственно в операторе вывода.
3. Итак, с описанием переменных закончили, можно начинать основную программу ключевым словом begin. И сразу же пишем к нему завершающий end с точкой на конце - таковы правила языка Паскаль. Вся программа размещается между двумя этими ключевыми словами.
4. Сначала организуем ввод. Это два оператора. Первый оператор выводит так называемое "приглашение" - сообщает о том, что нужно ввести. Второй оператор - это сам ввод.
5. А теперь, как было сказано выше, организуем вывод результатов. Все это сделает один оператор вывода. Программа готова!

var
  a, b: real;

begin
  Write('Введите стороны прямоугольника: '); Readln(a, b);
  Writeln('Периметр равен ', 2 * (a + b), ', площадь равна ', a * b)
end.

Тестовое решение:
Введите стороны прямоугольника: 4 3.16
Периметр равен 14.32, площадь равна 12.64
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота