Lerysik00
10.05.2022 15:45

Напишите программу через Pascal ABC Даны массивы a и b, вычислите сумму a и b. по примеру:
programm sum_;
var
i,n,s:integer;
a: array (1...100) of integer;
begin
writeln ('vvedite kol-vo elementov massiva a');
readln(n);
randomize:
for i:= 1 to n do
a(i):= random (100);
s:=0;
fori:=1 to n do
s:=s+a(i);
writeln ('summ=', s);
end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Вожделорд
16.07.2021 03:21

program amountnumbers;

var

 amount, number, a: integer;

begin

 write('Введите трехзначное число: ');

 read(number);

 writeln('Введите число А:');

 read(a);

 while number > 0 do

 begin

   amount := amount + number mod 10;

   number := number div 10;

 end;

 if (amount mod a = 0) then

   writeln('Да')

 else

   writeln('Нет');

end.

Объяснение:

program amountnumbers;  // Название программы

var

 amount, number, a: integer;  // Целочисленные переменные:

amount - сумма цифр трехзначного числа;number - трехзначное число, вводимое с клавиатуры;a - число для проверки на кратность.

begin  // Начало программы

 write('Введите трехзначное число: ');  // Вывод сообщения в консоль

 read(number);  // Считываем трехзначное число с клавиатуры

 writeln('Введите число А:');  // Вывод сообщения в консоль

 read(a);  // Считываем число А с клавиатуры

 while number > 0 do  // Пока значение переменной number > 0

 begin  // Начало цикла

   amount := amount + number mod 10;  // Сумма цифр = сумма цифр + последняя цифра числа

   number := number div 10;  // Отделяем последнюю цифру от числа

 end;  // Конец  цикла

 if (amount mod a = 0) then  // Если значение переменной amount делится на значение переменной A без остатка, тогда

   writeln('Да')  // Вывод сообщения в консоль

 else  // Иначе

   writeln('Нет');  // Вывод сообщения в консоль

end. // Конец программы

0,0(0 оценок)
Ответ:
БлинчикТян
13.02.2021 04:53

program amountn;

var

 amount, n, number, i: integer;

begin

 amount := 0;

 write('Введите количество чисел: ');

 read(n);

 for i := 1 to n do

 begin

   read(number);

   amount := amount + number;

 end;

 writeln('Сумма n чисел: ', amount);

end.

Объяснение:

program amountn;  // Название программы

var

 amount, n, number, i: integer;  // Целочисленные переменные:

amount - сумма чисел;n - количество чисел;number - сами числа;i - счетчик для цикла for.

begin  // Начало программы

 amount := 0; // Переменная, хранящая сумму, = 0

 write('Введите количество чисел: ');  // Вывод сообщения в консоль

 read(n);  // Считываем количество чисел с клавиатуры

 for i := 1 to n do  // Идём с единицы до n (цикл для ввода n чисел)

 begin  // Начало цикла

   read(number);  // Считываем число с клавиатуры

   amount := amount + number;  // К переменной, хранящей сумму, прибавляем число

 end;  // Конец цикла

 writeln('Сумма n чисел: ', amount);

end. // Конец программы

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота