basovaolga67
15.11.2022 01:20

Написать программу на с++, которая будет выводить прямоугольный двумерный массив, a[n][m], n и m вводятся с клавиатуры, элементы массива генерируются случайным образом з.ы. если что среда разработки - qt

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Steyflie
06.07.2020 11:16
Это невозможно. N и M должны быть константными значениями. То есть в виде переменных их не сделать => ввести с клавиатуры значения для константных значений нельзя. Можно сделать элементы массива рандомными:

#include <ctime>
int main() {
cout<<"Введите число a: ";    
double a,b;    
cin>>a;    
cout<<"Введите число b: ";    
cin>>b;    
double **massiv=new double*[10];
for(int i=0;i<10;i++)        
massiv[i]=new double[10];
for(int i=0;i<10;i++)    
{        
for(int j=0;j<10;j++)        
{            
massiv[i][j]=(double(rand()) / RAND_MAX) * (b - a) + a;            
cout<<setw(6)<<setprecision(3)<<massiv[i][j];        
}        
cout<<endl;    
}
} 

Но не иначе. 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота