Kissss1111
03.10.2021 21:28

написать программу по задаче где нужно найти S1, когда известно V, T, S. Задача сначало решена по блок схеме, теперь нужно написать программу по этой схеме.
Я начал с учителем, но он сказал дома доделать и я не знаю как


написать программу по задаче где нужно найти S1, когда известно V, T, S. Задача сначало решена по бл
написать программу по задаче где нужно найти S1, когда известно V, T, S. Задача сначало решена по бл

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
эльха1
09.10.2022 05:48

Объяснение:

Первая программа:

a = list(map(int,input().split()))

p = 0

for i in range (0,len(a)):

   if i % 3 == 0:

       p+= 1

print(p)

(Вводим список, прогоняем его по циклу for по всем элементам. Нумерация элементов идет с 0, если номер цикла при делении на 3 имеет остаток 0 (нацело делится), то в переменную p прибавляем 1. После цикла принтуем переменную p, количество элементов с индексом, кратным 3)

Вторая программа:

a,b = map(int,input().split())

summ = 0

p = 0

for i in range(a,b+1):

   if i % 3 == 0:

       summ += i

       p += 1

print(summ/p)

(Записываем 2 числа в одну строку, задаем переменную summ(сумма элементов, кратных 3) значение 0 и переменной p(количество таких чисел) значение 0. Прогоняем все числа от a до b(с шагом 1) по циклу for. Если число в диапазоне делится на 3 нацело, то к переменной summ прибавляем число, а к переменной p - единицу. После цикла выводим ср.арифметическое(сумму всех чисел делим на их количество)

Если что-то непонятно - спрашивайте.

0,0(0 оценок)
Ответ:
NastiaForever18
21.01.2022 00:52
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

№6

begin
  var a:=ArrRandom(ReadInteger('n='),-99,99).Println;
  Writeln('[',a.Min,';',a.Max,']')
end.

Пример
n= 13
72 -77 -88 -99 -2 -61 67 40 -30 -28 91 -56 29
[-99;91]

№9

begin
  var a:=ReadArrReal('Вводите:',ReadInteger('n='));
  Writeln('Положительных: ',a.Where(t->t>0).Count);
  Writeln('Отрицательных: ',a.Where(t->t<0).Count);
  Writeln('Нулевых: ',a.Where(t->t=0).Count)
end.

Пример
n= 10
Вводите: 3.7 12.6 -4 0 -13.2 0.7 0 14 2.12 0.004
Положительных: 6
Отрицательных: 2
Нулевых: 2

№16

begin
  var a:=Arr(-3.7,-3.1,-2.3,-1.6,-0.9,-0.2,0.5,1.2,1.9,2.6,3.3,4.0,4.2,5.4,
      1.92,1.76,1.52,1.26,0.95,0.45,0.71,1.10,1.38,1.61,1.82,2.00,2.05,2.32);
  var d:=a.Length div 2;
  for var i:=0 to d-1 do Writeln(a[i]:5:2,a[i+d]:20:3)
end.

Результат
-3.70               1.920
-3.10               1.760
-2.30               1.520
-1.60               1.260
-0.90               0.950
-0.20               0.450
 0.50               0.710
 1.20               1.100
 1.90               1.380
 2.60               1.610
 3.30               1.820
 4.00               2.000
 4.20               2.050
 5.40               2.320

№19

begin
  var n:=ReadInteger('n=');
  var a:=ArrRandom(n,-50,50); a.Println;
  var i:=1;
  while i<=n do begin
    Print(a[i-1]);
    i*=2
    end;
  Writeln
end.

Пример
n= 17
-43 -41 -37 -43 12 45 -34 -19 -38 33 -34 39 -40 33 -46 4 39
-43 -41 -43 -19 4
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота