умница06092006
27.07.2022 19:38

Составить программувычисления значений функцииy={█(cosnx+〖(x-2)〗^2+∛(n-1,) если x∈[0,n)@sinnx-(x+2)^2-∛(n+1), если x∈[-n,0))},в пяти точках полуинтервала [-n,n), используя операции отношения и логические операции, где n-номер студента в списке группы. pamagite pajalusta srocna

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Alinka291002
24.01.2021 22:32
ИСПРАВЛЕНО
---
Uses crt;
{описание переменных}
var a,b,c: array [1..20] of integer;
    x,sum:integer;
begin
     sum:=0; {обнуляем сумму}
     for x:=1 to 20 do {включаем цикл ввода массивов}
     begin
          write('a[',x,']:'); {вывод текста на экран}
          readln(a[x]); {ввод массива А}
          write('b[',x,']:'); {вывод текста на экран}
          readln(b[x]); {ввод массива В}
          c[x]:=a[x]+b[x]; {формируем массив С}
          if x mod 2=0 then
             sum:=sum+c[x];
     end;
     writeln; {переводим указатель на новую строку}
     for x:=1 to 20 do {цикл вывода массива С}
         writeln('c[',x,']:',c[x]); {вывод текста на экран}
     writeln('sum=',sum); {сумма четных элементов массива С}
end.
---
текст в фигурных скобках удалять не обязательно, он на код не влияет.
0,0(0 оценок)
Ответ:
vovazvyagin
15.05.2020 22:06

Если запись числа оканчивается на 8, то система счисления (далее - с/с) не может иметь основание меньше чем 8+1=9. В этой системе счисления представление числа 30 будет двухзначным (с одного разряда может быть представлено число, не превышающее 8, а двух разрядов достаточно для записи числа 9²-1=80, что превышает 30).

Двухзначное число может быть записано в с/с по основанию n следующим образом: na+b. По условию число оканчивается цифрой 8 и его значение равно 30. Получаем уравнение:

na+8=30 ⇒ na=22.

Раскладываем 22 на простые множители: 22=1х2х11

Решение уравнения в целых числах при условии n>8 дает два варианта ответов:

(n=11, a=2), (n=22, a=1).

Это порождает два числа:

Существует ли с/с по основанию n, в которой запись числа 30 будет одноразрядной?

Уравнение 8n=30 не имеет решений в целых числах, поэтому такой с/с не существует.

ответ: 30(10)=18(22)=28(11).

Подробнее - на -

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота