малика2071
02.01.2021 11:04

Написать программу которая в любой видимой фразе ищет букву а

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
rutasolntseva
15.08.2022 15:18

ответ:

. в нужно вывести все составные числа из промежутка [2; n]. код программы:

program lab3;

var i,n,j,s,l: integer;

m: real;

begin

readln (n);

for i: =2 to n do

begin

s: =trunc (sqrt (i));

for l: =2 to s do

begin

m: = i mod l;

if m=0 then

write (' ',i);

end;

end;

end.

но проблема - как только s становится больше 2, составные числа начинают несколько раз повторятся, т.к., например 12 делится и на 2 и на 3. вопрос: как мне сделать выход из цикла после первого успешного деления?

var

i, n, j, s, l: integer;

m: real;

begin

readln(n);

for i : = 2 to n do

begin

s : = trunc(sqrt(i));

for l : = 2 to s do

begin

m : = i mod l;

if m = 0 then

begin

write(' ', i);

break;

0,0(0 оценок)
Ответ:
dem0N1
04.07.2020 16:11
Для начала посчитаем, сколько бит информации было передано:
2 минуты и 45 секунд = 165 секунд
165 с * 128000 бит/с = 21120000 бит

Теперь вспомним, что такое частота дискретизация и уровни квантования. Дело в том, что аудио сигнал - это такая прикольная сложная синусоида. Чтобы записать сигнал в цифровом виде, каждую секунду сигнала как бы делят на промежутки (количество этих промежутков в секунде и есть частота дискретизации). Для каждого из этих промежутков записывается что-то вроде среднего значения высоты. Количество возможных значений - количество уровней квантования.
Но это так - если говорить очень упрощённо. Подробнее прочитайте в своём учебнике информатики.

Итак - у нас 256 уровней квантования. Значит каждое из значений можно записать 8 битами.
И на секунду у нас приходится 22000 таких записей.
То есть каждая секунда записи у нас кодируется 22000 * 8 = 176000 битами.

21120000 / 176000 = 120 секунд.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота