sidyakinanasty
10.03.2023 16:35

Написать программу которая проверяет состоит ли трёхзначное число из одинаковых цифр ( например 555). с объяснением. для 7 класса. предмет: информатика.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
bekker222
12.06.2020 04:04
Программа на языке PascalABC

program raf105;

var abc,ab,bc:integer;

begin

write('Введите трёхзначное число: ');

readln(abc);

ab:= abc mod 100;

bc:= abc div 10;

if ab = bc

 then writeln('Число состоит из одинаковых цифр')

 else writeln('Число не состоит из одинаковых цифр');

end.

Объяснение

Для выполнения задачи достаточно найти первые 2 цифры и последние 2 цифры если они равны, то число состоит из одинаковых цифр

abc mod 100 Убирает все сотни из числа.

Например было число 123, стало 23.

482 стало 82

abc div 10 Считает сколько в числе целых десяток, но не считает остаток.

Например было число 123, стало 12

482 стало 48

Сравнивание 2 первых и 2 последних цифр

253      25 и 53 не равны, значит число не состоит из одинаковых цифр

121       12 и  21 не равны, значит число не состоит из одинаковых цифр

111        11 и 11  равны, значит число состоит из одинаковых цифр

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота