kzifi
21.09.2022 16:09

Написать программу на паскале абс цикл с постусловием дано целое число n (> 1). вывести наименьшее из целых чисел k, для которых сумма 1 + 2 + … + k будет больше или равна n, и саму эту сумму.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
yoongi2017
03.10.2020 06:12
Var n,k,summ:integer;
begin
  write('Введи число N: ');
  readln(n);
  repeat begin
     k:=k+1;
     summ:=summ+k;
     end;
  until summ>=n;
  writeln('K=',k,', 1+..+',k,'=',summ,', ',summ,'>=',N);
end.  
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота