lacshenova
26.07.2020 09:58

Написать программу на языке Pascal Дано реальное число X.найти среднюю геометрическую последней цифры и первой цифры дробной части всего заданного реального числа​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nastiakosovic
01.12.2022 12:49

Объяснение:

Если после переустановки Windows 7 или 8.1, а также после их обновления до Windows 10 ваш компьютер не видит второй жесткий диск или второй логический раздел на диске (диск D, условно), в этой инструкции вы найдете два простых решения проблемы, а также видео руководство по ее устранению. Также описываемые должны если вы установили второй жесткий диск или SSD, он виден в БИОС (UEFI), но не виден в проводнике Windows.

В случае же если второй жесткий диск не показывается в БИОС, а произошло это после каких-либо действий внутри компьютера или просто после установки второго жесткого диска, то рекомендую в первую очередь проверить, а правильно ли все подключено:

0,0(0 оценок)
Ответ:
07Лизочек07
02.12.2020 14:51
1. В приведенном коде ошибка. Не хватает ";" в третьей строке снизу.
2. Немного изменим ваш код и получим искомое значение x
Искомое число х = 16293

var
  x, y, a, b, k: integer;

begin
  k:=10000;
  repeat
    x:=k;
    a := 0; b := 0; y := 1;
    while x > 0 do
    begin
      if (x mod 10) mod 2 = 0
        then
        a := a * 10 + x mod 10
      else begin
        y := y * 10;
        b := b * 10 + x mod 10
      end;
      x := x div 10
    end;
    a := a * y + b;
    k := k + 1;
    until a = 26391;
    writeln(a:8, k-1:8); 
end.

 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота