Yulia542
19.09.2021 15:32

Решить на paskal. чтобы открыть секретный сейф, агент 007 решил набирать в возрастающем порядке все трехзначные числа, в записи которых нет одинаковых цифр. составить программу, которая бы печатала все такие числа. определить, сколько времени потребуется ему в худшем случае для вскрытия сейфа, если для набора одного числа он тратит 2с?

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
skosachyov
29.07.2020 07:17
Program test ;
Var
a:integer;
Begin
For i:=0 to 9 do begin
For i1:=0 to 9 do begin
For i2:=0 to 9 do begin
If (i<>i1) and (i1<>i2) and (i<>i2) then begin
writeln(" Комбинация введенная агентом 007 - ",i*100+i1*10+i2);
a:=a+2;
End;
End;
End;
Writeln(" В ХУДШЕМ случае он затратит на подбор пароля. ", a div 60,"мин. ",a mod 60,"сек. ") ;
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота