ира1029
22.10.2020 18:42

Напишите 4 программы на C++ 1. Оценки, полученные спортсменом в соревнованиях по фигурному катанию (в ), хранятся в массиве из 18 элементов. В первых шести элементах записаны оценки по обязательной программе, в седьмом - двенадцатом – по короткой программе, в остальных – по произвольной программе. Выяснить, по какому виду программы спортсмен показал лучший результат.

2. Напишите программу, которая позволяет пользователю вводить целые числа, а затем сохраняет их в массиве типа int. Напишите функцию max (), которая обрабатывая элементы массива один за другим, находит наибольший. Функция должна принимать в качестве аргумента адрес массива и количество элементов в нем, а возвращать индекс наибольшего элемента. Программа должна вызывать эту функцию, а затем вывести наибольший элемент и его индекс. В случае если таких элементов несколько, вывести последний.

3. Задан одномерный массив целых чисел. Образуйте из него два отсортированных по возрастанию массива, содержащих четные и нечетные числа.

4. Задан генератором случайных чисел одномерный массив из действительных чисел. Найдите максимальное и минимальное число этого массива.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Flas003
01.09.2021 15:10

#include <iostream>

#include <set>

#include <vector>

using namespace std;

struct book{

   int name;

   int year;

   int k;

};

signed main() {

   ios_base::sync_with_stdio(0);

   cin.tie(0);

   cout.tie(0);

   vector<book> ans;

   int n;

   cin >> n;

   for(int i = 0; i < n; i++)

   {

       book bk;

       cin >> bk.name >> bk.year >> bk.k;

       if(bk.k >= 2 && bk.k <= 10)

           ans.push_back(bk);

   }

   for(auto i: ans)

       cout << i.name << " " << i.year << " " << i.k << "\n";

}

0,0(0 оценок)
Ответ:
azharalol
01.09.2021 15:10

#include <iostream>

#include <set>

#include <vector>

using namespace std;

struct book{

   int name;

   int year;

   int k;

};

signed main() {

   ios_base::sync_with_stdio(0);

   cin.tie(0);

   cout.tie(0);

   vector<book> ans;

   int n;

   cin >> n;

   for(int i = 0; i < n; i++)

   {

       book bk;

       cin >> bk.name >> bk.year >> bk.k;

       if(bk.k >= 2 && bk.k <= 10)

           ans.push_back(bk);

   }

   for(auto i: ans)

       cout << i.name << " " << i.year << " " << i.k << "\n";

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота