Rashmed
06.09.2020 18:26

Переменные k и m описаны в программе как целочисленные. Определите значение m переменной после выполнения следующего фрагмента программы:
Begin

Dat[1] := 12; Dat[2] := 18;

Dat[3] := 16; Dat[4] := 15;

Dat[5] := 12; Dat[6] := 12;

Dat[7] := 10; Dat[8] := 13;

m := 0;

for k := 1 to 8 do

if Dat[k] > m then

begin

m := Dat[k];

end;

writeln(m);

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Uliano4ka1
27.05.2022 18:00

Шестнадцатеричные цифры: 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, A (10), B (11), C (12), D (13), E (14), F(15).

– По условию цифры не превосходят 6, тогда поразрядные суммы не превосходят 6 + 6 = C. Отвергаем вариант 1: в нем появилось F.

– Поразрядные суммы, как следует из предыдущего наблюдения, записываются одной цифрой. Поэтому не подходит вариант 2, в котором 3 цифры.

– Цифры в результате должны идти в порядке возрастания, чего нет в варианте 4, 7 > 6.


Остаётся единственный вариант: 3) 8B. Он получится, например, если исходные числа равны 35 и 56

0,0(0 оценок)
Ответ:
egubiev
10.05.2023 04:20

program z1;
var
i,j,m,k,z,x,l:integer;
begin
readln(m);
for i:=0 to m do begin z:=1;
if i=0 then z:=1 else begin
x:=i;
while x<>0 do begin
z:=z*4;
x:=x-1;
end; end;
if ((z<m) and (z*4>m)) then writeln(i);
if z=m then writeln(i-1);
end;
end.

 

program z2;
var
i,j,n,k,z,x,l:integer;
begin
readln(n);
for i:=0 to n do begin z:=1;
if i=0 then z:=1 else begin
x:=i;
while x<>0 do begin
z:=z*2;
x:=x-1;
end; end;
if ((z>n) and (z/2<n)) then writeln(i);
if z=n then writeln(i+1);
end;
end.

 

program z3;
var
i,j,n,k,z,x,s:integer;
begin
readln(n); s:=0;
for i:=1 to n do begin z:=1;
for j:=i to 2*i do
z:=z*j;
s:=s+z; end;
writeln(s);
end.

 

время 2 ночи 

...думаю пора спать ) 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота