milankae
07.12.2020 23:16

Программа в C# Написать программу, выделив под массив динамически память. Обращаться к элементам массива необходимо используя указатель. Ограничения на функцию main 50 строк, на пользовательские функции – 30.
--Заполнить массив с клавиатуры. Удалить из массива все отрицательные значения.--
Заранее Буду рад любой

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
samuray99
25.09.2020 02:11
Сколь­ко су­ще­ству­ет раз­лич­ных на­бо­ров зна­че­ний ло­ги­че­ских пе­ре­мен­ных x1, x2, … x8, y1, y2, … y8, ко­то­рые удо­вле­тво­ря­ют всем пе­ре­чис­лен­ным ниже усло­ви­ям?

 

(x1 ∨ x2) ∧ ((x1 ∧ x2) → x3) ∧ (¬x1 ∨ y1) = 1

(x2 ∨ x3) ∧ ((x2 ∧ x3) → x4) ∧ (¬x2 ∨ y2) = 1

…

(x6 ∨ x7) ∧ ((x6 ∧ x7) → x8) ∧ (¬x6 ∨ y6) = 1

(x7 ∨ x8) ∧ (¬x7 ∨ y7) = 1

(¬x8 ∨ y8) = 1

 

В от­ве­те не нужно пе­ре­чис­лять все раз­лич­ные на­бо­ры зна­че­ний пе­ре­мен­ных x1, x2, … x8, y1, y2, … y8, при ко­то­рых вы­пол­не­на дан­ная си­сте­ма ра­венств. В ка­че­стве от­ве­та Вам нужно ука­зать ко­ли­че­ство таких на­бо­ров.

 

По­яс­не­ние.

Из по­след­не­го урав­не­ния на­хо­дим, что воз­мож­ны три ва­ри­ан­та зна­че­ний x8 и y8: 01, 00, 11. По­стро­им древо ва­ри­ан­тов для пер­вой и вто­рой пар зна­че­ний.

 

 

Таким об­ра­зом, имеем 16 на­бо­ров пе­ре­мен­ных.

Де­ре­во ва­ри­ан­тов для пары зна­че­ний 11:

 

 

По­лу­ча­ем 45 ва­ри­ан­тов. Таким об­ра­зом, си­сте­ма будет иметь 45 + 16 = 61 раз­лич­ных на­бо­ров ре­ше­ний.

 

ответ: 61
0,0(0 оценок)
Ответ:
didlok
09.10.2021 18:19

#include <iostream>

using namespace std;

int main(int argc, char** argv)

{

int a,b,s,p;

cout<<"Input a: ";

cin>>a;

cout<<"Input b: ";

cin>>b;

p = (a+b)*2;  

s= a*b;

cout<<"Perimetr: "<<p<<"\nPloschad: "<<s<<endl;

}

Диагональ не знаю как.

2. #include <iostream>

using namespace std;

int main(int argc, char** argv)

{

int a,b,c;

cout<<"Input a: ";

cin>>a;

cout<<"Input b: ";

cin>>b;

cout<<"Input c: ";

cin>>c;

if(a==b or a==c)

{

 cout<<"Yes!"<<endl;

}

else if(b==a or b==c)

{

 cout<<"Yes!"<<endl;

}

else if(c==a or c==b)

{

 cout<<"Yes!"<<endl;

}

else

{

 cout<<"Oops!"<<endl;

}

}

3. #include <iostream>

using namespace std;

int main(int argc, char** argv)

{

setlocale(LC_ALL, "Russian");

int a;

cout<<"Input a: ";

cin>>a;

switch(a)

{

 case 1:

 case 2:

 case 3:

  cout<<"Íèçêèé!"<<endl;

  break;

 case 4:

 case 5:

 case 6:

  cout<<"Ñðåäíèé!"<<endl;

  break;

 case 7:

 case 8:

 case 9:

  cout<<"Äîñòàòî÷íûé!"<<endl;

  break;

 case 10:

 case 11:

 case 12:

  cout<<"Âûñîêèé!"<<endl;

  break;

 default:

  cout<<"Error!"<<endl;

  break;

}

}

4. #include <iostream>

using namespace std;

int main(int argc, char** argv)

{

int a, a1, a2, a3, a4, a5, a6;

cout<<"Input a: ";

cin>>a;

a1=a/1000;

a2=a/100%10;

a3=a%100/10;

a4=a%10;

a5=a1;

a6=a3;

if(a5>a1 && a6>a3)

{

 cout<<"Number more"<<endl;

}

}

Вроде так

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота