Собака2609
09.09.2020 14:45

решить задачи на пайтоне 1 Напишите программу, которая по данному числу n от 1 до 9 выводит на экран n зверьков. Между двумя соседними зверьками также имеется пустой (из пробелов) столбец. Разрешается вывести пустой столбец после последнего зверька. Для упрощения рисования скопируйте зверька из примера в среду разработки.
^---^
( o o )
! = !/)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ванёк20012001
09.03.2022 09:38
Достоинство числовой - она сохранить числовые значения будь цены, счета, цифры, пароли. недостатки - не может хранить текст
Графическая - достоинства: Может хранить изображения, используемые как доказательства, но не может передавать звук.
Звуковая - передает звуки, музыку, голос. Недостаток не может передать изображение
Видео - может передавать кадры и изображения соединные в последовательность, но не может передавать звук.
Но если рационально и правильно соединить несколько типов информации, то мы сможем передать любые данные.
0,0(0 оценок)
Ответ:
alina200120
30.03.2020 13:11
Var
  n, k, t, i, counter, j: int64;
  c: array[1..10]of int64;
  a: array[1..100000]of int64;
  ar: array[1..10, 1..100000]of int64;
  count: array[1..10]of int64;
  b: boolean;

 label l1;

  begin
  b := true;
  counter := 0;
  read(n, k, t);
  for i := 1 to n do read(c[i]);
  for i := 1 to k do read(a[i]);
  l1:
  while (counter <> k) do
   begin
    for j := 1 to n do
     begin
      for i := 1 to c[j] do
       begin
        if(ar[j, i] <= a[counter + 1]) then
         begin
          ar[j, i] := t + a[counter + 1];
           counter := counter + 1;
          count[j] := count[j] + 1;
          b := false;
          goto l1;
        end;
      end;
    end;
    if(b = true) then counter := counter + 1;
    b := true;
  end;
  for i := 1 to n do write(count[i], ' ');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота