ndknmm
16.08.2021 14:58

Нужно написать программу на pascal abc net. суть программы такова, что нужно человеку сначала ввести n чисел, после чего программа должна сложить данные числа и эту сумму поделить на сумму чисел в числе,которое получилось в первой сумме, когда человек вводил числа. формула: где sum1= сумму n чисел, которые ввёл человек sum2=сумму чисел в числе, получившееся в результате сложения чисел, вводимых человеком. 100 за написание такой программы!

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kira183kira
21.08.2020 11:30
// PascalABC.NET 3.3

begin
  var n:=ReadInteger('n =');
  var a:=ReadSeqInteger('Введите '+n+' чисел: ',n);
  var sum1:=a.Sum;
  var x:=sum1;
  var sum2:=0;
  while (x>0) do 
   begin
   sum2:=sum2+x mod 10;
   x:=x div 10;
   end;
  writeln('sum1 = ',sum1,' sum2 = ',sum2,' sum1/sum2 = ',sum1/sum2);
end.

Пример:
n = 5
Введите 5 чисел:  2 7 4 3 5
sum1 = 21 sum2 = 3 sum1/sum2 = 7
Нужно написать программу на pascal abc net. суть программы такова, что нужно человеку сначала ввести
0,0(0 оценок)
Ответ:
ep53
21.08.2020 11:30
Ну должно быть как то так .
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота