катя5091
03.04.2023 20:40

Написать программу, которая в массиве случйных чисел с[1..5,1..5] меняет местами значения элементов главной и диагонали

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
keklol1990
30.09.2020 20:54

uses crt;

var C:array[1..5,1..5] of integer;

i,j,temp:integer;

 

begin

   randomize();

   for i:=1 to 5 do

      for j:=1 to 5 do

         C[i,j]:=random(1000);

   for i:=1 to 5 do begin

      t:=C[i,i];

      C[i,i]:=C[i,6-i];

      C[i,6-i]:=t;

   end

end.

0,0(0 оценок)
Ответ:
masha1248
30.09.2020 20:54

program pr;
uses crt;
Var i,j,b:integer;
C:array[1..5, 1..5] of integer;
Begin
for i:=1 to 5 do Begin
Writeln;
    for j:=1 to 5 do Begin C[i,j]:=random(100); Write(C[i,j],'|');  end;
     end;
for i:=1 to 5 do
     Begin
           b:=C[i,i];
           C[i,i]:=C[i,6-i];
           C[i,6-i]:=b;
      end;
Writeln;
      
for i:=1 to 5 do Begin
Writeln;
    for j:=1 to 5 do  Write(C[i,j],'|');
     end;
      

readln;
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота