Dimka14228
15.02.2021 21:30

Написать программу C++ Нужно написать программу: Симметричную монету бросают три раза. Найдите вероятность того, что орлов выпадет больше, чем решек.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Alex90111
12.10.2022 12:06

Плюсы:

1)Специально разработанные  программы оказывают в обработке файлов и документов

2)В  сети также можно воспользоваться необходимыми для учёбы доп. материалами.

3) всю необходимую инфу можно найти благодаря одному нажатию клавиши

4)социальные сети - знакомства - бесплатные электронные письма - независимо в какой стране находишся

Минусы:

1)Компьютерная сеть  затягивает человека в виртуальный мир, лишая его живого общения.

2)общения человека с компьютером – это ухудшение здоровья как психического, так и физического.

3)Человеку просто следует ограничивать себя в этом занятии

0,0(0 оценок)
Ответ:
Maruua1
01.04.2020 15:14
// PascalABC.NET 3.2, сборка 1403 от 16.03.2017
// Внимание! Если программа не работает, обновите версию!

function SumDigits(n:integer):integer;
begin
  Result:=0;
  while n>0 do begin
    Result+=n mod 10;
    n:=n div 10
    end
end;

begin
  var s:=ReadArrInteger('Вводите:',3).Select(x->SumDigits(x)).ToArray;
  var i:=s.IndexMax;
  var k:=s.Where(x->x=s[i]).Count;
  case k of
    1:begin
      Write('Сумма цифр наибольшая у ');
      case i of
        0:Write('первого');
        1:Write('второго');
        2:Write('третьего');
        end;
      Writeln(' числа')
      end;
    2:begin
      Write('Сумма цифр наибольшая у ');
      if s[0]=s[1] then Writeln('первого и второго чисел')
      else
        if s[0]=s[2] then Writeln('первого и третьего чисел')
        else Writeln('второго и третьего чисел')
      end;
    3:Writeln('Суммы цифр у всех трех чисел равны')
    end
end.

Примеры
Вводите: 102030 324 19
Сумма цифр наибольшая у третьего числа

Вводите: 16453 4320 56341
Сумма цифр наибольшая у первого и третьего чисел

Вводите: 12345 12354 54321
Суммы цифр у всех трех чисел равны
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота