SaraTyan
24.08.2022 01:59

Нужно написать программу на Си, которая бы считала значение функции: n и x вводятся с клаиватуры.


Нужно написать программу на Си, которая бы считала значение функции: n и x вводятся с клаиватуры.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
09Катя99
11.01.2021 09:18
Код на С++

// Example program#include <bits/stdc++.h>
using namespace std;
int main(){  int mas[100], i, maxl = -1, minl = 30000, sum = 0, k = 0, pro = 1;int n = 1;
while (n != 0) { cin >> n;   if (n != 0) {     k++; maxl = max(n, maxl); minl = min(n, minl); pro = pro * n; }  sum = sum + n;}
cout << k << endl;cout << sum << endl;cout << pro << endl;cout << sum / k << endl;cout << maxl << endl;cout << minl << endl;  return 0;  }
0,0(0 оценок)
Ответ:
taniussa1
11.01.2021 09:18
Program N94780249;
const
  s: longint = 0;
var
  x: longint;
  t: string;
  e: integer;
begin
  writeln('Вводите целые числа (0 - окончание ввода) : ');
  repeat
    repeat
      write('> ');
      readln(t);
      val(t, x, e);
      if e <> 0 then
        writeln('Ошибка! Повторите ввод. ')
    until e = 0;
    s += x
  until x = 0;
  if s = 0 then
    writeln('Числа не вводились. ')
  else
    writeln('Сумма введённых чисел = ', s, #10);
  write('Для завершения работы нажмите Enter...');
  readln
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота