Паскаль. Написать программу, которая формирует новый массив С размера 12, каждый элемент которого равен среднему геометрическому элементов массива А и В.
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016 // Внимание! Если программа не работает, обновите версию!
begin var a:=ReadArrReal(12).Select(x->real(x)).ToArray; Writeln('Тип массива ',a.GetType); Writeln('Максимальное нечетное: ',a.Where(x->Trunc(x).IsOdd).Max) end.
Пример 13 10 22 31 22 6 18 5 26 3 8 24 Тип массива System.Double[] Максимальное нечетное: 31
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016 // Внимание! Если программа не работает, обновите версию!
begin var c:=new Char[10]; for var i:=0 to 9 do c[i]:=ReadlnChar; var c1:=c[9]; var c2:=c[8]; c:=c.Where(a->(a<>c1) and (a<>c2)).ToArray; c.Println(',') end.
Пример а п е л ь с и н е ь а,п,л,с,и,н
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку