djdjsjsj
14.11.2020 18:40

с заданием
Написать программу решения системы линейных алгебраических уравнений методом LU-разложение.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
avgustreykh14
12.12.2022 10:18

 

Program Matrix; 

Uses Crt;
type matrix=array[1..3,1..3] of real;
var m:matrix;

 

procedure PrintMatrix(mas:matrix);
var j,k:integer;
begin
     for k:=1 to 3 do
           begin
               for j:=1 to 3 do
                     begin
                         write(mas[k,j]:7:2);
                      end;
                writeln;
         end;
end;

 

 

procedure Auto;
var i,j:integer;
begin
     randomize;
     for i:=1 to 3 do
           begin
               for j:=1 to 3 do
                     begin
                       m[i,j]:=25+random(21)+i;
                      end;
           end;
end; 

 

begin 

     clrscr; 

     Auto;

     PrintMatrix(m);

     readkey;

end;

 

 

 

0,0(0 оценок)
Ответ:
austry1337
05.12.2022 07:42

 

 

Ну так во первых  обяъвление процедуры должно быть

procedure InputMas1(var mas1:Tmas );

 

 

 во вторых ты забыл  end;  т.е 

 

 

begin
for i:=1 to 10 do
      begin
           mas1[i]:=random(n);
           Write(mas1[i]:3);
     end;

 end; {забытый end}

 

 

в третьих ты  не написал основную прграмму т.е забыл begin и не вызвал процедуру 

InputMas1

 

 

begin

     clrscr;
     InputMas1(mas1);

     readkey;
end. 

 

 

 Итого прога должна выглядеть примерно так

 

 

program Massiv
Uses Crt;
const n=10;
type TMas=array[1..n] of integer;
var mas1:TMas;


procedure InputMas1(var mas1:TMas);
var i:integer;

begin
     for i:=1 to 10 do
        begin
        mas1[i]:=random(n);
        Write(mas1[i]:3);
       end;
end;
{Основная прога}
begin
clrscr;
InputMas1(mas1);
readkey;
end.

 

 

 

 

Держи ! Пользуйся на здоровье и будь внимательнее.

 

 

 

 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота