ZEWER
10.02.2022 19:54

Паскаль. Написать программу, которая формирует новый массив С, из массива А все элементы стоящие на четных местах, а из В элементы стоящие на нечетных местах. Размеры массивов 4х4. Ввод массивов А и В осуществлять в строчку, через пробел. Массив С должен представлять из себя матрицу.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
user666triplesix
19.04.2020 00:51

Вот тебе в паскале


program ryad_chisel;

var N, t:integer;

begin

read(N);

t:=(N*(N+1))div 2;

if t mod 2 =1 then writeln('IMPOSSIBLE')

else begin

     if N mod 2 =0 then begin

                        t:=N div 4;

                        repeat

                        write('+');

                        t:=t-1;

                        until t=0;

                        t:=N div 2;

                        repeat

                        write('-');

                        t:=t-1;

                        until t=0;

                        t:=N div 4;

                        repeat

                        write('+');

                        t:=t-1;

                        until t=0;

                        end

     else begin

          t:=((N+1) div 4)-1;

          repeat

          write('+');

          t:=t-1;

          until t=0;

          t:=((N-1) div 2)+1;

          repeat

          write('-');

          t:=t-1;

          until t=0;

          t:=(N+1) div 4;

          repeat

          write('+');

          t:=t-1;

          until t=0;

          end

     end    

end.

0,0(0 оценок)
Ответ:
matumaxim
09.05.2020 20:53

1. Берілген нүктелер арқылы өтетін түзудің теңдеуін жазыңыз: А(2;1) В(-1;2). [2 ұпай]

2. Шеңбердің берілген теңдеуі бойынша оның центрінің координаталары мен радиусын табыңыз: (х-4)2 +(у+8)2 =36 [1 ұпай]

3. нүктелері берілген.

a) төбелерінің координаталары бойынша салыңыз; [1 ұпай]

b) қабырғаларының ұзындықтарын табыңыз; [3 ұпай]

c) түрін анықтаңыз (теңқабырғалы, теңбүйірлі, тікбұрышты); [2 ұпай]

d) берілген үшбұрыштың ауданын есептеңіз. [2 ұпай]

4. Төбелері А (1;-1) В (0;1) С (4;3) және Д (5;1) нүктелері болатын төртбұрыштың тіктөртбұрыш болатынын дәлелдеп, оның ауданын табыңыз. Ол үшін:

a) төбелерінің координаталары бойынша сызбасын салыңыз; [1 ұпай]

b) қабырғаларының ұзындықтарын табыңыз; [4 ұпай]

c) диагональдарын анықтап, дәлелдеңіз; [2 ұпай]

d) тіктөртбұрыштың ауданын есептеңіз. [2 ұпай]

Объяснение

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота