егорка140
15.02.2020 00:12

Задача: Дан массив целых чисел в диапазоне от -30000 до 30000. Отсортировать его по возрастанию. Методом простого выбора.

Формат ввода:

В первой строке - количество элементов массива не превосходящее 100. На второй строке через пробел элементы массива.

Формат вывода:

Элементы отсортированного массива на одной строке через пробел.

Пример входных данных

5
4 3 5 1 2
Пример выходных данных

1 2 3 4 5
Answer:(penalty regime: 0, 0, ... %)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Zizosia
25.12.2020 17:52

2-ое задание:

#include <iostream>

int main() {

int number;

std::cout << "Введите число: " << std::endl;

std::cin >> number;

if (number > 0)

 std::cout << "Положительное" <<std::endl;

else if (number < 0)

 std::cout << "Отрицательное" << std::endl;

else

 std::cout << "Ноль" << std::endl;

return 0;

}

1-ое задание:

#include <iostream>

int main() {

double dollars, grivnas;

std::cout << "Введите кол-во долларов: " << std::endl;

std::cin >> dollars;

grivnas = dollars * 28.3;

std::cout << dollars << " доллар-(а, ов) в гривнах " << grivnas << std::endl;

return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
samnsk100617
27.07.2021 02:06

for

примеры

(Pascal)

for i := 1 to 10 do

  s:=s+1;

 

(C#,C++)

for (int i=0;i<10;i++) {

   s+=i;

}

 

(Ruby)

for i in 1..10

  s=s+i

end

 

(VB, VBA, Basic,..)

for i = 1 to 10

  s=s+i

next i

 

По умлчанию шагом счетчика является 1. Обычно шаг счетчика можно менять фразой by или step by. Хотя увы такое есть не во всех языках

 

(C#,C++)

for (int i=0;i<10;i=i+2) {

   s+=i;

}

 

(VB, VBA, Basic,..)

for i = 1 to 10 step by 2

  s=s+i

next i

 

Например в паскале возможен только обратный отсчет

for i := 10 downto 1 do

  s:=s+1;

 

еще for примечателен тем, что даже если конец меньше начала (в варианте увеличения счета), то цикл все равно пройдет один раз. Правда не знаю подпадают ли под это правило языки из группы С

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота