Виолета131
18.04.2020 06:47

Написать программу Pascal ABC Net по вычислению функции y=3x-4 при x=3, 5, 7, 9, 11

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Amelia2018
12.01.2023 05:13
Материк, носящий название Австралия, занимает площадь 7 659 861 км² в Южном полушарии. Береговая линия имеет длину 35 тыс. км, ширина континента составляет 4000 км, а длина достигает 3700 км.Рядом с Австралией находятся такие острова, как Тасмания и Новая Гвинея. Западное и южное побережье Австралии омываются водами Индийского океана, а восточное и северное побережья – морями Тихого океана.Это Тиморское, Коралловое, Арафурское и Тасманово моря. Также возле северо-восточного побережья Австралии находится самый крупный коралловый риф в мире, Большой Барьерный риф тянется более чем на 2000 км. Ширина его может достигать 150 км.Крайней западной точкой материка является мыс Стип-Пойнт, восточной – мыс Байрона, северной крайней точкой является мыс Йорк, а южная точка Австралии – это мыс Саут-Пойнт.В большой мере Австралия расположена в жарком тепловом поясе, а берега материка немного изрезаны. На юге Австралии находится Большой Австралийский залив, а залив Карпентария находится на севере, как и два полуострова Кейп-Йорк и Арнемленд. Внутренними морями Австралия связана с Юго-Восточной Азией.История исследования материкаСамый маленький из всех, этот материк пришлось искать довольно долго. В 1606 году был открыт пролив, который отделяет Новую Гвинею от материка. Этот пролив был назван именем открывателя – Торрес. И в этом же году мореплаватель Янсзон оказался на побережье залива Карпентария.Через несколько десятилетий, в 1643 году, было доказано, что Австралия представляет собой единую сушу. Доказал это мореплаватель Тасман и также он открыл остров, который впоследствии был назван его именем.В 1770 году Джеймс Кук, будучи известным английским мореплавателем, оказался на восточном побережье самой Австралии. С тех пор начался процесс колонизации англичанами, изучение Австралии, как отдельного континента, и хозяйственное освоение ее территории.Земли Австралии стали называть Новым Южным Уэльсом. В те времена Австралия стала местом ссылки для преступников, осужденных за мелкие нарушения. Позднее поселение, считавшееся британской колонией, было названо Сиднеем. Оно было основано 26 января в 1788 году – основателем является капитан Артур Филип.А территория Тасмании присоединилась к остальным землям Австралии в 1829 году. Середина 19 века – это начало «золотой лихорадки» на территории Австралии, именно для этого периода характерны волны массовой иммиграции в Австралию.А в 1901 году – 1 января – Австралия стала независимым государством, образовав Австралийский Союз.
0,0(0 оценок)
Ответ:
artemsavenkov
18.04.2021 14:18
// PascalABC.NET 3.3, сборка 1605 от 31.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var P:=new real[3,2]; // массив координат вершин
  for var i:=0 to 2 do
    (P[i,0],P[i,1]):=ReadReal2('Введите x и y вершины '+(i+1));
  // длины сторон
  var L:(real,real)->real:=(x,y)->Sqrt(x**2+y**2);
  var a:=L(P[1,0]-P[0,0],P[1,1]-P[0,1]);
  var b:=L(P[2,0]-P[1,0],P[2,1]-P[1,1]);
  var c:=L(P[0,0]-P[2,0],P[0,1]-P[2,1]);
  if (a+b>c) and (a+c>b) and (b+c>a) then // треугольник существует
    if (a=b) or (a=c) or (b=c) then Writeln('Треугольник равнобедренный')
    else Writeln('Треугольник не равнобедренный')
  else Writeln('Треугольник построить невозможно')  
end.

Замечание: для сборок ниже 1603 от 30.12.2017 необходимо заменить
Sqrt(x**2+y**2) на Sqrt(x*x+y*y)

Даны действительные числа x1,y1,x2,y2,x3,y3. выясните является треугольник с такими вершинами равнос
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота