России5544
25.04.2022 00:03

РЕШИТЬ ЗАДАЧУ НА С++ Требуется написать программу, которая определяет и выводит сумму только положительных из трёх данных чисел a, b и c.

Формат входных данных
Входной поток содержит три целых числа в одной строке — a, b и c (∣∣a∣∣,∣∣b∣∣,∣∣c∣∣≤5⋅108).

Формат выходных данных
Выведите одно число — искомую сумму.

входные данные
5 -5 1
выходные данные
6

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
DAVIDUIOP
29.11.2020 15:55

#include <iostream>

using namespace std;

int main()

{

   int a, b, c;

   int amount = 0;

   cin >> a >> b >> c;

   if (a > 0)

   {

       amount += a;

   }

   if (b > 0)

   {

       amount += b;

   }

   if (c > 0)

   {

       amount += c;

   }

   cout << amount;

}

Объяснение:

#include <iostream>  // Библиотека ввода - вывода

using namespace std;  // Пространство имен

int main()

{

   int a, b, c;  // Создание целочисленных переменных a, b, c

   int amount = 0;  // Создание целочисленной переменной amount, которая будет хранить сумму положительных чисел. Значение переменной = 0

   cin >> a >> b >> c;  // Ввод с клавиатуры значений переменных a, b, c

   if (a > 0)  // Если значение переменной a > 0

   {

       amount += a;  // К значению переменной amount прибавляем значение переменной a

   }

   if (b > 0)  // Если значение переменной b > 0

   {

       amount += b;  // К значению переменной amount прибавляем значение переменной b

   }

   if (c > 0)  // Если значение переменной b > 0

   {

       amount += c;  // К значению переменной amount прибавляем значение переменной c

   }

   cout << amount;  // Вывод значения переменной amount

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота