крузейро
24.05.2020 09:21

Составьте программу для вычисления среднего арифметического чисел от 250 до 500, кратных 5 и 7 одновременно. с цикла for на паскале

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
rita239
24.05.2020 10:01

Вот программа, написанная на паскале.
Комментарий: sum - общая сумма всех чисел, делящихся на 5 и на 7 одновременно, count - их количество.


ответ: 385


Составьте программу для вычисления среднего арифметического чисел от 250 до 500, кратных 5 и 7 однов
0,0(0 оценок)
Ответ:
dimasikkas39
24.05.2020 10:01

var s: real;

      i,n: integer;

begin

  s:=0;

  n:=0;

  for i:=250 to 500 do begin

    if (i mod 5=0) and (i mod 7=0) then begin s:=s+i; n:=n+1;

                                                         end;

                                end;

  s:=s/n;

  writeln(s);

end.

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота