KNV1980G
15.01.2020 11:03

Движение шарика в замкнутом объеме.

напишите программу моделирования движения шарика в замкнутом объеме на языке c, используя библиотеку “txlib.h”.
движение равномерное прямолинейное (законы выполняются). соударения со стенками . трением пренебречь.

в программе смоделируйте движение трёх шариков. соударениями пренебречь.

выход из программы по нажатию кнопки esc.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Nikita111r2
26.09.2022 16:27

Программа:

Pascal:

№1)

const max = 100;

var

 arr: array[1..max] of real;

 i: integer;

 n, A, B: integer;

begin

 randomize;

 repeat

   write('n = ');

   readln(n);

 until n in [1..max];

 write('A = ');  readln(A);

 write('B = ');  readln(B);

 writeln('Массив: ');

 for i := 1 to n do begin

   arr[i] := random(B - A + 1) + A;

   write(arr[i]:5:1);

 end;

end.

№2)

const max = 100;

var

 arr: array[1..max] of real;

 A, B, s, pr: real;

 n, i, j, arrMax, arrMin: byte;

begin

 randomize;

 s := 0;

 arrMax := 1;

 arrMin := 1;

 

 repeat

   write('n = ');

   readln(n);

 until n in [1..max];

 write('A = ');  readln(A);

 write('B = ');  readln(B);

 writeln('Массив: ');

 for i := 1 to n do begin

   arr[i] := random(B - A + 1) + A;

   write(arr[i]:5:1);

 end;

 

 for i := 1 to n do begin

   if abs(arr[i]) < abs(arr[arrMin]) then arrMin := abs(i);

   if abs(arr[i]) > abs(arr[arrMax]) then arrMax := abs(i);

 end;

 if abs(arrMax - arrMin) = 1 then begin

   writeln(); writeln('Между минимальным и максимальным значениями нет элементов.')

 end

 else begin

   if arrMax < arrMin then begin

     j := arrMin;

     arrMin := arrMax;

     arrMax := j;

   end;

   pr := 1;

   for i := arrMin + 1 to arrMax - 1 do pr := pr * arr[i];

   writeln();  writeln('Произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами: ', pr:0:2);

 end;

   

end.

0,0(0 оценок)
Ответ:
иринакодр
09.03.2021 14:59

<!DOCTYPE html>

<html lang="en">

<head>

   <meta charset="utf-8">

   <style type="text/css">

       #circle {

           border-radius: 100px;

           width: 100px;

           height: 100px;

           position: absolute;

           top: 50%;

           left: 50%;

           transform: translate(-50%, -50%);

           cursor: pointer;

       }

       #circle.red {

           background-color: red;

       }

       #circle.green {

           background-color: green;

       }

       #circle.orange {

           background-color: orange;

       }

   </style>

   <title>Title</title>

</head>

<body>

<div id="circle" class="red"></div>

<скрипт>

   colors = ["red", "green", "orange"]

   document.getElementById("circle").addEventListener("click", function(e) {

       const element = this;

       let currentColor = element.classList.value

       if (currentColor === "orange"){

           currentColor = colors[0]

       } else {

           currentColor = colors[colors.indexOf(currentColor)+1]

       }

       element.classList = currentColor

   })

</скрипт>

</body>

</html>

P.S. При загрузке фулл кода выдает ошибку от сайта.. Поэтому на фотке весь код


создайте страничку с красным кружком (100х100) и напишите скрипт который будет при каждом клике на к
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота