Gunelka23333
08.08.2020 06:21

ПАСКАЛЬ. Составить программу нахождения произведения цифр целого числа.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
DazaOtaku
28.11.2020 18:59

program comp;

var

 number, composition, last_number: integer;

begin

 composition := 1;

 read(number);

 while (number > 0) do

 begin

   last_number := number mod 10;

   composition := composition * last_number;

   number := number div 10;

 end;

 write(composition);

end.

Объяснение:

program comp;  // Название программы

var

 number, composition, last_number: integer;  // Создание целочисланных переменных:

number - число, которое вводится с клавиатуры;composition - переменная для хранения произведения цифр числа;last_number - переменная, которая будет хранить цифры числа.

begin  // Начало программы

 composition := 1;  // Переменной composition присваиваем значение 1

 read(number);  // Считываем число с клавиатуры

 while (number > 0) do  // Пока переменная number > 0 выполняем

 begin  // Начало цикла

   last_number := number mod 10;  // Берем последнюю цифру от числа (остаток от деления на 10)

   composition := composition * last_number;  // В переменную composition записываем произведение переменной composition и переменной last_number

   number := number div 10;  // Отделяем последнюю цифру от числа (целочисленное деление на 10)

 end;  // Конец цикла

 write(composition);  // Вывод значения переменной composition

end. // Конец программы

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота