рлжжх
11.08.2020 11:07

Составьте программу, которая находит первую позицию пробела в строке s, А ЗАТЕМ ПРОВЕРЯЕТ, есть ли еще пробелы в данной строке. Строка вводится с клавиатуры. паскальабс

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
помогитепж19
26.11.2020 20:24

var

s: string;

i,dop: integer;

begin

writeln('Введите строку:');

readln(s);

writeln(pos(' ', s));

dop := Length(s);

for i := 1 to dop do

if s[i]=' ' then

write(' ')

end.

Если нужно вывести ВСЕ пробелы, то:

dop := Length(s);

for i := 1 to dop do

if s[i]=' ' then

write(' ')

end.

Проверка на наличие 2+ пробелов (размещать в конце (перед end.)):

if i > 3 then

 write('Пробелы ещё есть')

else

 writeln('Пробелов больше нет');

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота