misterwotblitz
26.06.2021 13:23

Написать программу с использованием подпрограммы для вычисления суммы s=1+3+5..+a"
(паскаль)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
dol2711
10.10.2020 20:19

var a:integer;

function SumN (n:integer):integer;

 var

   i,sum:integer;

begin

 i:=1;

 sum:=0;

 while i<=n do  

   begin

     sum:=sum+i;

     i:=i+2;

   end;

 if n mod 2 = 0 then sum:=sum+n;

 sumN:=sum;

end;

begin

 readln(a);

 writeln('Сумма нечётных до "a"(вкулючая в сумму "a", даже если оно чётное): ',sumN(a));

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота