Ppapit
03.09.2022 19:16

Составьте программу, которая запрашивает пол учеников ('ж'или 'м') и их количество(от 5 до 30) и выдаёт сообщение. протокол: введите пол и количество: ж 13 в классе сейчас тринадцать девочек на паскале

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:

Ох и намудрил с этой программой))

 

program school; 
var a:char;
b:real;
c,d:boolean;
begin
Writeln ('Введите пол (м или ж) и количество учеников');

repeat
write ('Пол - '); readln (a);
if upcase(a)='Ж' then c:=true;
if upcase(a)='М' then c:=true;
if c=true then write else
writeln ('Вы должны ввести использовать символы "м" или "ж"');
until c=true;

repeat
write ('Количество учеников данного пола от 5 до 30 - '); readln (b);
if b<5 then d:=false else d:=true;
if b>30 then d:=false else d:=true;
if d=true then
begin
if upcase(a)='Ж' then writeln ('В классе сейчас ',b,' девоч.');
if upcase(a)='М' then writeln ('В классе сейчас ',b,' мальч.');
end;
until d=true;
end.

0,0(0 оценок)
Ответ:
сахарок191
11.06.2020 04:42

А я вот так сделал)

Написано в pascal.abc.net

 

Var
x : integer;
sex : char;
function numbers(n: integer): string;
begin
case n of
5: Result := 'пять';
6: Result := 'шесть';
7: Result := 'семь';
8: Result := 'восемь';
9: Result := 'девять';
10: Result := 'десять';
11: Result := 'одиннадцать';
12: Result := 'двенадцать';
13: Result := 'тринадцать';
14: Result := 'четырнадцать';
15: Result := 'пятнадцать';
16: Result := 'шестнадцать';
17: Result := 'семнадцать';
18: Result := 'восемнадцать';
19: Result := 'девятнадцать';
20: Result := 'двадцать';
21: Result := 'двадцать один';
22: Result := 'двадцать два';
23: Result := 'двадцать три';
24: Result := 'двадцать четыре';
25: Result := 'двадцать пять';
26: Result := 'двадцать шесть';
27: Result := 'двадцать семь';
28: Result := 'двадцать восемь';
29: Result := 'двадцать девять';
30: Result := 'тридцать';
31: Result := 'тридцать один';
32: Result := 'тридцать два';
33: Result := 'тридцать три';
34: Result := 'тридцать четыре';
35: Result := 'тридцать пять';
end;
end;
begin
writeln ('Введите пол и количество:');
Readln (sex,x);
write('В классе сейчас ', numbers(x));
if sex = 'м' then write(' мальчиков')
else if sex = 'ж' then write(' девочек');
end.

 

 

 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота