валерка1973
22.10.2020 01:13

Задание 1. Тестирование готовой линейной программы. 1. Запустите программу Раsса1 ABC.
2. Откройте готовую программу, для этого выполните команды: Файл-Открыть в предложенном списке программ выберите файл Произведение а и в.pas
3. Перед вами появится программа, позволяющая умножить два целых числа.
4. Запустите ее на выполнение, для этого Программа-Выполнить. На экране появится сообщение: Введите два числа. Курсор мигает в следующей строке, введите два любых числа и нажмите Еntег.
5. Просмотрите результат выполнения программы.

Задание 2.
Измените исходную программу, чтобы она находила сумму двух чисел.
Сохраните программу нажав Файл-Сохранить как под названием Задание2_Ковальков
Задание 3.
Измените исходную программу, чтобы она находила частное двух чисел.
Сохраните программу нажав Файл-Сохранить как под названием Задание3_Ковальков
Задание 4.
Измените исходную программу, чтобы она находила сумму четы¬рех чисел.
Сохраните программу нажав Файл-Сохранить как под названием Задание4_Ковальков
Составление простейших программ
Задание 5.
Составьте программу нахождения значения выражения (а-(d+21)*2)*(с-7*к), где значения переменных а, d, с и к вводятся с клавиатуры (результат выполнения программы покажите преподавателю). Сохраните программу нажав Файл-Сохранить как под названием Задание5_Ковальков

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
147387492
03.02.2022 23:16
#include <iostream>
#include <cstdlib>
#include <ctime>
int main()
{
    using namespace std;
    const int n = 10;  //количество элементов массива
    int Arr[n];

    //как-нибудь заполняем массив
    srand(time(0));
    int i;
    for (i = 0; i < n; ++i)
        Arr[i] = rand() % (n * n) + 1;

    //выведем его на экран
    for (i = 0; i < n; ++i)
        cout << Arr[i] << "   ";
    cout << endl;

    int p;
    for (i = 1; i < n; ++i)
    {
        p = i;
        while (p % 2 == 0)
            p /= 2;
        if (p == 1)
            cout << "Arr[" << i << "] = " << Arr[i] << endl;
    }
    cout << endl;
    return 0;
}
0,0(0 оценок)
Ответ:
jamshidbek
19.02.2022 15:30
Для начала поясню что значат * и ? в маске. *-это последовательность символов, то есть любое количество символов. От 0 до бесконечности. Нам не важно что это за символы важен сам факт их существования или не существования. ?-это только один символ. Опять же, не важно какой, главное, чтобы он был там.
Первая маска: A?B*.*C?*. Её можно интерпретировать как A[любой символ]B[последовательность символов или ничего]. [последовательность символов или ничего]C[любой символ] [последовательность символов или ничего].
Под такие условия подходят 5 файлов, которые переходят в каталог friends:
ABBCBD.CDDBA
ACBDC.ACBA
AABBCCDD.DDCCD
ACBCACD.AABBCCDD
ADBCCAD.CADABC
Почему не подходят остальные? ABDCC.ACBDA – нет символа в начале между A и B. BABCDA.ABCD  - нет символа A в начале. AABACADA?CDBDADCB – нет точки.
Следующая маска: *B?C*.??*D*. На человеческий: [любой символ] B] [последовательность символов или ничего]C[любой символ]. [любой символ] [любой символ] [последовательность символов или ничего]D [последовательность символов или ничего]
Результат – 3 файла в папке family :
ABBCBD.CDDBA
AABBCCDD.DDCCD
ADBCCAD.CADABC
Остальные: ACBCACD.AABBCCDD – после единственной B сразу идёт C; ACBDC.ACBA – после точки нет D.
ответ:
ABBCBD.CDDBA
AABBCCDD.DDCCD
ADBCCAD.CADABC
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота