Lera2010K
07.01.2022 23:59

Напишите программу, которая проверяет, что каждая из трех целочисленных переменных вводится с клавиатуры положительно, в противном случае она создает соответствующую взаимосвязь.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
BEKISKAKOV75
31.05.2022 02:42

Шапка

Форма блока шапки

Именно с шапки начинается любой скрипт. Блок шапка — это некое событие (например щелчок по зелёному флагу), которое вызвано взаимодействием пользователя с программой. Они скруглены сверху и имеют выступ снизу для прикрепления других блоков. Существуют 7 блоков шапок, 6 из которых в категории события, 1 в категории управления.

Обычный блок

Форма обычного блока

Обычные блоки – это блоки команд. Они прикрепляются сверху выступом и прикрепляют снизу выступом вовнутрь, то есть остальные блоки могут быть помещены как сверху, так и снизу обычных блоков. Всего насчитывают 71 такой блок – это самая большая категория блоков.

Логический блок

Форма логического блока

Логические блоки – это условия, определяющие правильно или ложно заданное условие. Спроси своего друга «2 умножить на 2 будет 4?» и попроси его ответить только «Да» или «Нет». Твой друг станет этаким логическим блоком. Они имеют форму шестиугольника и всего насчитывается 12 таких блоков.

Репортёр

Форма блоков репортёров

Блоки репортёры дают какие-либо значения. Они могут быть как числами, так и строками. Например, спроси друга: "Сколько будет 2 + 2?". Он ответит "4". Твой друг станет этаким репортёром. Кстати, репортёрами могут быть и переменные. Форма репортёров – закруглённые прямоугольники. Всего насчитывают 30 таких блоков, не считая репортёров переменных и списков.

Обвивающий блок

Форма обвивающего блока

Обвивающие блоки – это блоки повторения или блоки условий. Их насчитывают всего 5 и их можно найти во вкладке "Управление". Имеют выступ вовнутрь сверху и простой выступ внутри и снаружи.

Закрывающий блок

Форма закрывающего блока

Закрывающие блоки заканчивают скрипт или все процессы. Имеют выступ вовнутрь сверху и не могут иметь прикреплённых блоков снизу. Всего существует 2 закрывающих блока, и оба находятся во вкладке "Контроль".

Категории блоков

Объяснение:

0,0(0 оценок)
Ответ:
Jama133
28.03.2020 01:38
Var
f: array[1..10] of integer;
i,suma,sumb:integer;
begin
randomize;
for i:=1 to 10 do
begin f[i]:=random(10)+10;
write(f[i],' ');
end;
suma:=0;
sumb:=0;
for i:= 1 to 10 do
if f[i] mod 2 = 0 then
suma:=suma+f[i];
else
sumb:sumb+f[i];
writeln('Сумма четных: ',suma);
writeln('Сумма нечетных: ',sumb);
end.

var
f: array[1..8] of integer;
i,k,sumb:integer;
begin
randomize;
for i:=1 to 8 do
begin f[i]:=random(10)+10;
write(f[i],' ');
end;
k:=0;
sumb:=0;
for i:= 1 to 8 do
if f[i] mod 2 = 0 then
k:=k+1;
else
sumb:sumb+f[i];
writeln('Количество четных: ',k);
writeln('Сумма нечетных: ',sumb);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота