xZeoNx
09.12.2020 15:19

Написать программу на Паскале для решения следующей задачи: с клавиатуры вводятся 2 числа. Определить, являются ли они четными и кратными 6, а также, какое из чисел больше, его (большее число) заменить числом 100.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Alisa6666666666666
21.06.2021 05:47
Const   N = 10;   
var   a, S1, S2: Integer;   
i, Q1, Q2: Byte;   
begin   
S1 := 0; Q1 := 0;   
S2 := 0; Q2 := 0;  
writeln('Введите ', N, ' чисел:');   
for i := 1 to N do 
begin     
read(a);     
if a < 0 then 
begin      
S1 := S1 + a;       
inc(Q1)     
end;     
if a > 0 then 
begin       
S2 := S2 + a;       
inc(Q2)     
end;   
end;   
writeln;   
if Q1 > 0 then 
begin     
writeln('Сумма отрицательных чисел: ', S1);     
writeln('Количество отрицательных: ', Q1)   
end   
else 
writeln('Отрицательных нет');   
if Q2 > 0 then
begin     
writeln('Сумма положительных чисел: ', S2);     
writeln('Количество положительных: ', Q2)   
end   
else 
writeln('Положительных нет') 
end.
0,0(0 оценок)
Ответ:
marushakeduard
21.06.2021 05:47
Const   N = 10;   
var   a, S1, S2: Integer;   
i, Q1, Q2: Byte;   
begin   
S1 := 0; Q1 := 0;   
S2 := 0; Q2 := 0;  
writeln('Введите ', N, ' чисел:');   
for i := 1 to N do 
begin     
read(a);     
if a < 0 then 
begin      
S1 := S1 + a;       
inc(Q1)     
end;     
if a > 0 then 
begin       
S2 := S2 + a;       
inc(Q2)     
end;   
end;   
writeln;   
if Q1 > 0 then 
begin     
writeln('Сумма отрицательных чисел: ', S1);     
writeln('Количество отрицательных: ', Q1)   
end   
else 
writeln('Отрицательных нет');   
if Q2 > 0 then
begin     
writeln('Сумма положительных чисел: ', S2);     
writeln('Количество положительных: ', Q2)   
end   
else 
writeln('Положительных нет') 
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота